summaryrefslogtreecommitdiff
path: root/development/python-pmw/python-pmw.SlackBuild
diff options
context:
space:
mode:
authorRobby Workman <rworkman@slackbuilds.org>2011-03-16 01:13:49 -0500
committerRobby Workman <rworkman@slackbuilds.org>2011-03-20 12:33:01 -0500
commit7a1b4848a3d34a263544fadf08178c91c12fbad0 (patch)
tree8987d0fc908e371dfa87445425f59c7514075b37 /development/python-pmw/python-pmw.SlackBuild
parent987d45e99a299c3b24418b2976e8ec9d5f3bf404 (diff)
downloadslackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.gz
python/*: Moved a lot of Python stuff here
The criteria for whether something "belongs" in Development or Libraries or Python or ... is admittedly arbitrary. As a general rule, if it could be either Libraries or Python, it's Python. Otherwise, pick one and we'll go from there... Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'development/python-pmw/python-pmw.SlackBuild')
-rw-r--r--development/python-pmw/python-pmw.SlackBuild90
1 files changed, 0 insertions, 90 deletions
diff --git a/development/python-pmw/python-pmw.SlackBuild b/development/python-pmw/python-pmw.SlackBuild
deleted file mode 100644
index 4b66fc0b95..0000000000
--- a/development/python-pmw/python-pmw.SlackBuild
+++ /dev/null
@@ -1,90 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-pmw
-
-# Copyright 2007-2009 LukenShiro <lukenshiro@ngi.it>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-pmw
-VERSION=${VERSION:-1.3.2}
-BUILD=${BUILD:-3}
-TAG=${TAG:-_SBo}
-
-# Automatically determine the architecture we're building on:
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-SRC_PRGNAM=Pmw
-SRC_SUBDIR=Pmw_1_3
-
-if [ "$ARCH" = "i486" ]; then
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-# Python site-packages directory
-PYTHONDIR="/usr/lib${LIBDIRSUFFIX}/python2.6/site-packages"
-
-# Exit on most errors
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRC_PRGNAM.$VERSION
-tar xvf $CWD/$SRC_PRGNAM.$VERSION.tar.gz
-cd $SRC_PRGNAM.$VERSION/src/$SRC_PRGNAM
-chown -R root:root . || true
-chmod -R u+w,go+r-w,a-s .
-
-# Move documentation files
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-mv README $PKG/usr/doc/$PRGNAM-$VERSION
-mv $SRC_SUBDIR/doc $PKG/usr/doc/$PRGNAM-$VERSION/html
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-# Manual installation because python setup.py install seems to not be working
-mkdir -p $PKG/$PYTHONDIR/$SRC_PRGNAM/$SRC_SUBDIR
-cp -a $SRC_SUBDIR/{bin,contrib,demos,lib,tests,__init__.py} \
- $PKG/$PYTHONDIR/$SRC_PRGNAM/$SRC_SUBDIR
-cp -a __init__.py Alpha_99_9_example $PKG/$PYTHONDIR/$SRC_PRGNAM
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}