summaryrefslogtreecommitdiff
path: root/development/amaya/patches
diff options
context:
space:
mode:
authorMatteo Bernardini <ponce@slackbuilds.org>2012-09-25 14:39:13 +0200
committerRobby Workman <rworkman@slackbuilds.org>2012-09-26 00:00:45 -0500
commitd5ad0f5d0615b98b5865896be4e8c2adabe926a6 (patch)
tree82d207f17211176f60421f93830e28f4c782fd33 /development/amaya/patches
parent656d2dee56f21478a3b7f8b89ba1260b962bfd04 (diff)
downloadslackbuilds-d5ad0f5d0615b98b5865896be4e8c2adabe926a6.tar.gz
development/amaya: Updated for version 11.4.4.
Added the foreign dictionaries, built over the system's raptor and wxPython (so added them as dependencies) Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'development/amaya/patches')
-rw-r--r--development/amaya/patches/amaya-fix-thotlib-png14.patch56
-rw-r--r--development/amaya/patches/explicite_linking2.patch24
-rw-r--r--development/amaya/patches/gzread.patch21
3 files changed, 101 insertions, 0 deletions
diff --git a/development/amaya/patches/amaya-fix-thotlib-png14.patch b/development/amaya/patches/amaya-fix-thotlib-png14.patch
new file mode 100644
index 0000000000..2231db2de2
--- /dev/null
+++ b/development/amaya/patches/amaya-fix-thotlib-png14.patch
@@ -0,0 +1,56 @@
+diff -aur Amaya11.3.1/Amaya/thotlib/image/pnghandler.c Amaya11.3.1.new/Amaya/thotlib/image/pnghandler.c
+--- Amaya11.3.1/Amaya/thotlib/image/pnghandler.c 2009-09-09 11:54:50.000000000 +0200
++++ Amaya11.3.1.new/Amaya/thotlib/image/pnghandler.c 2010-08-17 20:42:10.823505508 +0200
+@@ -10,9 +10,9 @@
+ * R. Guetari (W3C/INRIA) - Initial Windows version
+ */
+
++#include "png.h"
+ #include "thot_gui.h"
+ #include "thot_sys.h"
+-#include "png.h"
+ #include "constmedia.h"
+ #include "typemedia.h"
+ #include "picture.h"
+@@ -128,13 +128,13 @@
+ png_byte **ppbRowPointers;
+ unsigned char *pixels;
+ unsigned int i, j, passes;
+- unsigned long lw, lh;
++ png_uint_32 lw, lh;
+ int iBitDepth, iColorType;
+ double dGamma;
+
+ /* Checks the eight byte PNG signature*/
+ fread (pbSig, 1, 8, pfFile);
+- if (!png_check_sig (pbSig, 8))
++ if (png_sig_cmp (pbSig, 0, 8))
+ return NULL;
+ /* create the two png(-info) structures*/
+ png_ptr = png_create_read_struct (PNG_LIBPNG_VER_STRING,
+@@ -169,13 +169,13 @@
+ png_set_strip_16 (png_ptr);
+ /* Grayscale =>RGB or RGBA */
+ if (iColorType == PNG_COLOR_TYPE_GRAY || iColorType == PNG_COLOR_TYPE_GRAY_ALPHA)
+- png_set_gray_to_rgb (png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+ /* Palette indexed colors to RGB */
+ if (iColorType == PNG_COLOR_TYPE_PALETTE)
+ png_set_palette_to_rgb (png_ptr);
+ /* 8 bits / channel is needed */
+ if (iColorType == PNG_COLOR_TYPE_GRAY && iBitDepth < 8)
+- png_set_gray_1_2_4_to_8(png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+ /* all transparency type : 1 color, indexed => alpha channel*/
+ if (png_get_valid (png_ptr, info_ptr,PNG_INFO_tRNS))
+ png_set_tRNS_to_alpha (png_ptr);
+@@ -822,7 +822,7 @@
+ TtaReadClose (fp);
+ if (ret != 8)
+ return FALSE;
+- ret = png_check_sig ((png_byte*)buf, 8);
++ ret = !png_sig_cmp ((png_byte*)buf, 0, 8);
+ if (ret) return (TRUE);
+ return(FALSE);
+ }
+
diff --git a/development/amaya/patches/explicite_linking2.patch b/development/amaya/patches/explicite_linking2.patch
new file mode 100644
index 0000000000..8219763488
--- /dev/null
+++ b/development/amaya/patches/explicite_linking2.patch
@@ -0,0 +1,24 @@
+diff -Naur Amaya11.3.1.orig/Amaya/amaya/Makefile.in Amaya11.3.1.new/Amaya/amaya/Makefile.in
+--- Amaya11.3.1.orig/Amaya/amaya/Makefile.in 2012-01-14 18:53:00.000000000 +0100
++++ Amaya11.3.1.new/Amaya/amaya/Makefile.in 2012-01-14 18:55:12.000000000 +0100
+@@ -21,7 +21,7 @@
+ $(GL_LIBRARIES) $(GTK_GL_LIBRARIES) $(FREETYPE_LIBRARIES) $(XFT_LIBRARIES) \
+ $(AMAYA_LIBWWW_LIBS) \
+ @AMAYA_RAPTOR_LIBS@ \
+- $(WX_LIBRARIES)
++ $(WX_LIBRARIES) -lpng14 -ljpeg -lexpat -lwwwssl
+
+ AMAYA = @top_srcdir@/amaya
+
+diff -Naur Amaya11.3.1.orig/Amaya/thotlib/Makefile.in Amaya11.3.1.new/Amaya/thotlib/Makefile.in
+--- Amaya11.3.1.orig/Amaya/thotlib/Makefile.in 2012-01-14 18:53:00.000000000 +0100
++++ Amaya11.3.1.new/Amaya/thotlib/Makefile.in 2012-01-14 18:55:45.000000000 +0100
+@@ -351,7 +351,7 @@
+
+ ../bin/print : $(THOTK_OBJ) $(DISPLAY_OBJ) $(PRINT_OBJ) \
+ ../amaya/libCSS.a
+- $(CXX) $(LDFLAGS) -o $@ $(THOTK_OBJ) $(DISPLAY_OBJ) $(PRINT_OBJ) ../amaya/libCSS.a $(LIBS)
++ $(CXX) $(LDFLAGS) -o $@ $(THOTK_OBJ) $(DISPLAY_OBJ) $(PRINT_OBJ) ../amaya/libCSS.a $(LIBS) -lpng14 -ljpeg
+ @$(ECHO) "====>" print is done
+
+ CEXTRACT= ../bin/cextract
diff --git a/development/amaya/patches/gzread.patch b/development/amaya/patches/gzread.patch
new file mode 100644
index 0000000000..c2644dc197
--- /dev/null
+++ b/development/amaya/patches/gzread.patch
@@ -0,0 +1,21 @@
+--- Amaya11.4.4/Amaya/amaya/html2thot.c.old 2012-03-07 10:53:27.904494374 +0100
++++ Amaya11.4.4/Amaya/amaya/html2thot.c 2012-03-07 11:20:46.931113208 +0100
+@@ -4349,7 +4349,7 @@
+ WorkBuffer = FileBuffer;
+ }
+ // need to read a new set of characters
+- LastCharInWorkBuffer = gzread (infile, &FileBuffer[StartOfRead],
++ LastCharInWorkBuffer = gzread ((gzFile) infile, &FileBuffer[StartOfRead],
+ INPUT_FILE_BUFFER_SIZE - StartOfRead);
+ // add previous read characters not managed yet
+ LastCharInWorkBuffer += StartOfRead;
+--- Amaya11.4.4/Amaya/amaya/Xml2thot.c.old 2012-03-07 11:21:30.994445257 +0100
++++ Amaya11.4.4/Amaya/amaya/Xml2thot.c 2012-03-07 11:22:04.644444274 +0100
+@@ -5847,6 +5847,6 @@
+ while (!endOfFile && !XMLNotWellFormed && !XMLInvalidToken)
+ {
+ /* read the XML file */
+- res = gzread (infile, bufferRead, COPY_BUFFER_SIZE);
++ res = gzread ((gzFile) infile, bufferRead, COPY_BUFFER_SIZE);
+ if (res < 0)
+ return;