summaryrefslogtreecommitdiff
path: root/desktop/anki/anki.SlackBuild
diff options
context:
space:
mode:
authorTimothy Pollard <sbo@timp.com.au>2014-03-17 16:01:02 +0700
committerErik Hanson <erik@slackbuilds.org>2014-03-21 13:01:18 -0500
commit9f2663fdb74d0bea4ae5cf063eac66fc7dd59940 (patch)
tree7eb51817f552afcde98f9ddd41d6abfe2066f94d /desktop/anki/anki.SlackBuild
parent8b0802e9583dd59d91b529ba26350e19c79a356f (diff)
downloadslackbuilds-9f2663fdb74d0bea4ae5cf063eac66fc7dd59940.tar.gz
desktop/anki: Updated for version 2.0.22 + New Maintainer.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop/anki/anki.SlackBuild')
-rw-r--r--desktop/anki/anki.SlackBuild67
1 files changed, 29 insertions, 38 deletions
diff --git a/desktop/anki/anki.SlackBuild b/desktop/anki/anki.SlackBuild
index 17083f5265..77f6eaa7ec 100644
--- a/desktop/anki/anki.SlackBuild
+++ b/desktop/anki/anki.SlackBuild
@@ -5,37 +5,16 @@
# Written by Giuseppe Scalzi <giuseppe[at]osgate[dot]org>
PRGNAM=anki
-VERSION=${VERSION:-1.2.9}
+VERSION=${VERSION:-2.0.22}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
+ARCH="noarch"
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -46,28 +25,40 @@ tar xvf $CWD/$PRGNAM-$VERSION.tgz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Doing this manually since the included Makefile isn't very flexible (it always
+# installs the anki binary as ${DESTDIR}${PREFIX}/local/bin/anki for example),
+# and there isn't a lot of things that need copying.
+
+mkdir -p $PKG/usr/bin
+cp -a runanki $PKG/usr/bin/anki
-# Fix sqlite table problem (without this anki isn't able to create new decks)
- sed -i 's/\"sqlite_stat1\"/\"sqlite_stat1\",\"sqlite_stat2\"/' libanki/anki/deck.py
+mkdir -p $PKG/usr/share/pixmaps
+cp -a anki.xpm anki.png $PKG/usr/share/pixmaps/
-cd libanki
-python setup.py install --root=$PKG
-cd ..
-python setup.py install --root=$PKG
+mkdir -p $PKG/usr/share/mime/packages
+cat anki.xml > $PKG/usr/share/mime/packages/anki.xml
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+mkdir -p $PKG/usr/share/applications
+cp -a anki.desktop $PKG/usr/share/applications/
+
+mkdir -p $PKG/usr/man/man1
+cp -a anki.1 $PKG/usr/man/man1
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- COPYING CREDITS README README.development README.translating ChangeLog ChangeLog.old \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE LICENSE.logo README README.development $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+mkdir -p $PKG/usr/share/anki
+cp -av anki aqt designer locale oldanki thirdparty $PKG/usr/share/anki/
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh