summaryrefslogtreecommitdiff
path: root/audio/jkmeter/jkmeter.SlackBuild
diff options
context:
space:
mode:
authorB. Watson <yalhcru@gmail.com>2019-12-02 09:53:02 -0500
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2019-12-15 17:06:24 +0700
commit3a8429595263a698fe66eb22a7e4c26c1c8034c5 (patch)
tree933785b0a5ce8bd1add6718700e397992e75955f /audio/jkmeter/jkmeter.SlackBuild
parent1c72f0976dc6623634b0e0abbe1a61c1d7db134b (diff)
downloadslackbuilds-3a8429595263a698fe66eb22a7e4c26c1c8034c5.tar.gz
audio/jkmeter: Updated for version 0.6.5.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'audio/jkmeter/jkmeter.SlackBuild')
-rw-r--r--audio/jkmeter/jkmeter.SlackBuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/audio/jkmeter/jkmeter.SlackBuild b/audio/jkmeter/jkmeter.SlackBuild
index e0180a559c..22196d945f 100644
--- a/audio/jkmeter/jkmeter.SlackBuild
+++ b/audio/jkmeter/jkmeter.SlackBuild
@@ -7,7 +7,7 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
PRGNAM=jkmeter
-VERSION=${VERSION:-0.6.1}
+VERSION=${VERSION:-0.6.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -47,11 +47,8 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
if [ "${FORCE_SLACK_CFLAGS:-no}" = "yes" ]; then
sed -i \
@@ -60,6 +57,8 @@ if [ "${FORCE_SLACK_CFLAGS:-no}" = "yes" ]; then
source/Makefile
fi
+sed -i 's,pkgconf,pkg-config,' source/Makefile
+
make -C source PREFIX=/usr DESTDIR=$PKG all install
strip $PKG/usr/bin/$PRGNAM