summaryrefslogtreecommitdiff
path: root/audio/abcde/abcde.SlackBuild
diff options
context:
space:
mode:
authorHeinz Wiesinger <pprkut@slackbuilds.org>2010-05-11 20:30:42 +0200
committerHeinz Wiesinger <pprkut@slackbuilds.org>2010-05-11 20:30:42 +0200
commit5953bc5be2592ce5e491acbe6b0c170ba0f7a42b (patch)
tree57104f80afe1c3bddfbe5ca928cfcd1e731ad92a /audio/abcde/abcde.SlackBuild
parent4ce0dbc9f70c1c1d7b4cb95c8e1c1e7ff1b1f904 (diff)
downloadslackbuilds-5953bc5be2592ce5e491acbe6b0c170ba0f7a42b.tar.gz
audio/abcde: Moved from multimedia
Diffstat (limited to 'audio/abcde/abcde.SlackBuild')
-rw-r--r--audio/abcde/abcde.SlackBuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/audio/abcde/abcde.SlackBuild b/audio/abcde/abcde.SlackBuild
new file mode 100644
index 0000000000..dee9c05230
--- /dev/null
+++ b/audio/abcde/abcde.SlackBuild
@@ -0,0 +1,80 @@
+#!/bin/sh
+# Slackware build script for abcde
+# abcde has a dependency of cd-discid, see the README
+
+# Copyright 2007 Jim Capozzoli <saltmiser@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Modified by the SlackBuilds.org project
+
+set -e
+
+PRGNAM=abcde
+VERSION=2.3.3
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+rm -rf $TMP/$PRGNAM-$VERSION
+
+cd $TMP
+tar -xzvf $CWD/$PRGNAM\_$VERSION.orig.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# Fix mandir and remove setting of ownership during install
+# The mandir can easily be changed by passing a 'mandir' variable to the
+# 'make install' process, but the setting of ownership isn't so easy to
+# work around without a patch. This isn't an issue if the SlackBuild
+# script is run as root, but I'm guessing that I'm not the only person who
+# likes to test a script as normal user before running it as root, and the
+# ownership setting in the Makefile will break installs as a normal user.
+# --rworkman
+patch -p1 < $CWD/Makefile.diff
+
+make
+make install DESTDIR=$PKG || exit
+
+# Let's not overwrite the config file if it already exists
+mv $PKG/etc/$PRGNAM.conf $PKG/etc/$PRGNAM.conf.new
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING FAQ README TODO changelog examples $PKG/usr/doc/$PRGNAM-$VERSION
+find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+( cd $PKG/usr/man || exit
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz