summaryrefslogtreecommitdiff
path: root/academic
diff options
context:
space:
mode:
authorAleksandar Samardzic <asamardzic@gmail.com>2010-05-11 22:21:35 +0200
committerRobby Workman <rworkman@slackbuilds.org>2010-05-11 22:21:35 +0200
commit570d10d553c1755218cffd6c4ecc8aefd373ee11 (patch)
treecb0d8080befe399aaf92a441bebf35e8644bbf15 /academic
parentb7d2872eb8846716dafde560546c1daec2c04e72 (diff)
downloadslackbuilds-570d10d553c1755218cffd6c4ecc8aefd373ee11.tar.gz
academic/matplotlib: Updated for version 0.98.0
Diffstat (limited to 'academic')
-rw-r--r--academic/matplotlib/README12
-rw-r--r--academic/matplotlib/matplotlib.SlackBuild39
-rw-r--r--academic/matplotlib/matplotlib.info10
-rw-r--r--academic/matplotlib/slack-desc2
4 files changed, 35 insertions, 28 deletions
diff --git a/academic/matplotlib/README b/academic/matplotlib/README
index 9ca76c5376..d899f0695f 100644
--- a/academic/matplotlib/README
+++ b/academic/matplotlib/README
@@ -1,9 +1,7 @@
-Matplotlib is a plotting library for Python which uses syntax similar to
-MATLAB. The library provides a "pylab" interface which is procedural
-and based on a state machine, like OpenGL. There is also an OOP
-interface which has less thorough documentation and greater complexity.
-Using the OOP interface, matplotlib plots can be embedded in
-applications using generic GUI toolkits like wxPython, Qt or GTK.
+Matplotlib strives to produce publication quality 2D graphics for
+interactive graphing, scientific publishing, user interface
+development and web application servers targeting multiple user
+interfaces and hardcopy output formats. There is a 'pylab' mode which
+emulates matlab graphics
Matplotlib requires NumPy, which is also available at SlackBuilds.org.
-Also, pygtk is an optional dependency.
diff --git a/academic/matplotlib/matplotlib.SlackBuild b/academic/matplotlib/matplotlib.SlackBuild
index 3e49aa3e00..e68e20ef57 100644
--- a/academic/matplotlib/matplotlib.SlackBuild
+++ b/academic/matplotlib/matplotlib.SlackBuild
@@ -2,32 +2,41 @@
# Slackware build script for matplotlib
-# Written by Aleksandar B. Samardzic <asamardzic@matf.bg.ac.yu>
+# Written by Aleksandar Samardzic <asamardzic@gmail.com>
-NAME=matplotlib
-VERSION=0.90.1
+PRGNAM=matplotlib
+VERSION=${VERSION:-0.98.0}
ARCH=${ARCH:-i486}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
-PKG=${PKG:-$TMP/package-$NAME}
+PKG=${PKG:-$TMP/package-$PRGNAM}
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
fi
+set -e
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
-cd $TMP || exit 1
-rm -rf $NAME-$VERSION
-tar xvf $CWD/$NAME-$VERSION.tar.gz || exit 1
-cd $NAME-$VERSION || exit 1
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -35,17 +44,17 @@ python setup.py build
python setup.py install --root $PKG
( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
)
-mkdir -p $PKG/usr/doc/$NAME-$VERSION
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
install -m 0644 API_CHANGES CHANGELOG INSTALL INTERACTIVE KNOWN_BUGS \
- NUMARRAY_ISSUES README TODO $PKG/usr/doc/$NAME-$VERSION
-cat $CWD/$NAME.SlackBuild > $PKG/usr/doc/$NAME-$VERSION/$NAME.SlackBuild
+ README.txt TODO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$NAME-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/academic/matplotlib/matplotlib.info b/academic/matplotlib/matplotlib.info
index 5c82bc49f4..1cf93d47f0 100644
--- a/academic/matplotlib/matplotlib.info
+++ b/academic/matplotlib/matplotlib.info
@@ -1,8 +1,8 @@
PRGNAM="matplotlib"
-VERSION="0.90.1"
+VERSION="0.98.0"
HOMEPAGE="http://matplotlib.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/matplotlib/matplotlib-0.90.1.tar.gz"
-MD5SUM="e1344bd72660e7c9c0b7540a72cc45b8"
-MAINTAINER="Aleksandar B. Samardzic"
-EMAIL="asamardzic@matf.bg.ac.yu"
+DOWNLOAD="http://downloads.sourceforge.net/matplotlib/matplotlib-0.98.0.tar.gz"
+MD5SUM="4b50915bb3ef983fb695f2270c069862"
+MAINTAINER="Aleksandar Samardzic"
+EMAIL="asamardzic@gmail.com"
APPROVED="rworkman"
diff --git a/academic/matplotlib/slack-desc b/academic/matplotlib/slack-desc
index 30b477b4d5..0308217fb4 100644
--- a/academic/matplotlib/slack-desc
+++ b/academic/matplotlib/slack-desc
@@ -5,7 +5,7 @@
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
- |-----handy-ruler------------------------------------------------------|
+ |-----handy-ruler--------------------------------------------------|
matplotlib: matplotlib (a Python 2D plotting library)
matplotlib:
matplotlib: Matplotlib is a plotting library for Python which uses