summaryrefslogtreecommitdiff
path: root/academic/grace/patches/xmgrace-strip.patch
diff options
context:
space:
mode:
authorB. Jogai <jogaib at comcast {dot} net>2010-05-13 00:57:17 +0200
committerRobby Workman <rworkman@slackbuilds.org>2010-05-13 00:57:17 +0200
commit42c6960dbf4b6a4d623172f3775ea86b96b8902a (patch)
tree7b8aab1b646c487468e69ab20fdfc686aca9ce96 /academic/grace/patches/xmgrace-strip.patch
parent0655c91b45832dbb4bce53b1d524550fdd26db6e (diff)
downloadslackbuilds-42c6960dbf4b6a4d623172f3775ea86b96b8902a.tar.gz
academic/grace: Added to 13.0 repository
Diffstat (limited to 'academic/grace/patches/xmgrace-strip.patch')
-rw-r--r--academic/grace/patches/xmgrace-strip.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/academic/grace/patches/xmgrace-strip.patch b/academic/grace/patches/xmgrace-strip.patch
new file mode 100644
index 0000000000..5ac62995cc
--- /dev/null
+++ b/academic/grace/patches/xmgrace-strip.patch
@@ -0,0 +1,33 @@
+--- auxiliary/Makefile
++++ auxiliary/Makefile
+@@ -27,7 +27,7 @@
+ install : $(AUXILIARIES) $(PROGRAMS) $(SCRIPTS)
+ $(MKINSTALLDIRS) $(DESTDIR)$(GRACE_HOME)/auxiliary
+ for i in $(AUXILIARIES); do $(INSTALL_DATA) $$i $(DESTDIR)$(GRACE_HOME)/auxiliary; done
+- for i in $(PROGRAMS); do $(INSTALL_PROGRAM) -s $$i $(DESTDIR)$(GRACE_HOME)/bin; done
++ for i in $(PROGRAMS); do $(INSTALL_PROGRAM) $$i $(DESTDIR)$(GRACE_HOME)/bin; done
+ for i in $(SCRIPTS); do $(INSTALL_PROGRAM) $$i $(DESTDIR)$(GRACE_HOME)/bin; done
+
+ tests : dummy
+--- grconvert/Makefile
++++ grconvert/Makefile
+@@ -42,7 +42,7 @@
+
+ install : $(PROG)
+ $(MKINSTALLDIRS) $(DESTDIR)$(GRACE_HOME)/bin
+- $(INSTALL_PROGRAM) -s $(PROG) $(DESTDIR)$(GRACE_HOME)/bin/$(PROG)
++ $(INSTALL_PROGRAM) $(PROG) $(DESTDIR)$(GRACE_HOME)/bin/$(PROG)
+
+ dummy :
+
+--- src/Makefile
++++ src/Makefile
+@@ -60,7 +60,7 @@
+
+ install : $(GRACE)
+ $(MKINSTALLDIRS) $(DESTDIR)$(GRACE_HOME)/bin
+- $(INSTALL_PROGRAM) -s $(GRACE) $(DESTDIR)$(GRACE_HOME)/bin/$(GRACE)
++ $(INSTALL_PROGRAM) $(GRACE) $(DESTDIR)$(GRACE_HOME)/bin/$(GRACE)
+ cd $(DESTDIR)$(GRACE_HOME)/bin; $(RM) $(GRBATCH); $(LN_S) $(GRACE) $(GRBATCH)
+
+ tests : dummy