summaryrefslogtreecommitdiff
path: root/academic/avl/Makefile_patches
diff options
context:
space:
mode:
authorDaniel Prosser <dpross1100@msn.com>2016-12-29 10:39:52 +0000
committerDavid Spencer <idlemoor@slackbuilds.org>2016-12-30 23:30:11 +0000
commit587cf3a20e297e888865b4bf9ed971155cb66c73 (patch)
tree9b09e62117d6cc26f9d1edf84e4a8cfe97ad3505 /academic/avl/Makefile_patches
parent6a49973171dd9d61eb0c5cbeceb62f9c36072235 (diff)
downloadslackbuilds-587cf3a20e297e888865b4bf9ed971155cb66c73.tar.gz
academic/avl: Added (aerodynamic analysis).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'academic/avl/Makefile_patches')
-rw-r--r--academic/avl/Makefile_patches/Makefile.avl.patch123
-rw-r--r--academic/avl/Makefile_patches/Makefile.eispack.patch28
-rw-r--r--academic/avl/Makefile_patches/config.make.plotlib.patch25
3 files changed, 176 insertions, 0 deletions
diff --git a/academic/avl/Makefile_patches/Makefile.avl.patch b/academic/avl/Makefile_patches/Makefile.avl.patch
new file mode 100644
index 0000000000..72f218e36d
--- /dev/null
+++ b/academic/avl/Makefile_patches/Makefile.avl.patch
@@ -0,0 +1,123 @@
+--- bin/Makefile 2013-10-06 19:34:54.000000000 -0400
++++ bin/Makefile.avl 2016-09-27 21:49:02.000000000 -0400
+@@ -2,8 +2,7 @@
+ # Makefile for AVL
+ #
+
+-BINDIR = /home/codes/bin/
+-INSTALLCMD = install -s
++BINDIR = $(DESTDIR)/usr/bin/
+
+ SRC = ../src
+
+@@ -18,92 +17,27 @@
+ matrix.o spline.o sgutil.o \
+ second.o
+
+-PLTOBJ = ../plotlib/libPlt.a
+-EIGOBJ = ../eispack/eispack.a
+-## EIGOBJ = eispack.o
+-
+-###================================================
+-### Default compilers and flags
+-FC = f77
+-FFLAGS = -O
+-PLTLIB = -lX11
+-FTNLIB =
++PLTOBJ = ../plotlib/libPlt_gDP.a
++EIGOBJ = ../eispack/eispack_gDP.a
+
+-#Subroutine SECOND source file
+-SECOND = second_g77.f
+-
+-##--------------------------
+-
+-# Uncomment flags for desired machine...
+-
+-##--------------------------
+-### DEC Alpha with OSF and DEC f77/f90 compiler
+-#FC = f77
+-#FFLAGS = -fast -O4 -tune host
+-##--------------------------
+-### SGI setup
+-#FC = f77
+-#FFLAGS = -O2
+-##--------------------------
+-## Uncomment for RS/6000
+-#FFLAGS = -O -qextname
+-##--------------------------
+-## Uncomment for HP-9000
+-#FFLAGS = -O +ppu
+-#FTNLIB = -U77
+-##--------------------------
+-### Absoft Linux f77
+-#FC = f77
+-#FFLAGS = -O -f -s -W -B108 -N34
+-##--------------------------
+-### f2c/gcc compiler driver
+-#FC = fort77
+-#FFLAGS = -O2 -fomit-frame-pointer
+-##--------------------------
+-### GNU g77
+-#FC = g77
+-#FFLAGS = -O3
+-##--------------------------
+-### Intel Fortran Compiler 8.x
+-FC = ifort
+-FFLAGS = -O
+-PLTLIB = -L/usr/X11R6/lib -lX11
+-SECOND = second_ifc.f
+-#FTNLIB = -Vaxlib
+-##--------------------------
+-### double-precision option (also need double precision Eispack and libPlt)
+-FFLAGS = -O -r8
+-PLTOBJ = ../plotlib/libPltDP.a
+-
+-##---------------------------------------
+-## Uncomment for Mac OSX gfortran
+ FC = gfortran
+
+-ACHK = -fbounds-check -finit-real=inf -ffpe-trap=invalid,zero,denormal
+-#ACHK =
+-
++#ACHK = -fbounds-check -finit-real=inf -ffpe-trap=invalid,zero,denormal
++ACHK =
++PLTLIB=-lX11
++FTNLIB=
+
+-#FTNLIB = -Vaxlib
+-FTNLIB =
+ SECOND = second_g77.f
+
+-DP =
+-PLTOBJ = ../plotlib/libPlt_gSP.a
+-EIGOBJ = ../eispack/eispack_gSP.a
+-
+-#DP = -fdefault-real-8
+-#PLTOBJ = ../plotlib/libPltDP.a
+-#EIGOBJ = ../eispack/eispack_gDP.a
+-
+-FFLAGS = -O -m64 $(ACHK) $(DP)
+-##---------------------------------------
+-
++DP = -fdefault-real-8
+
++FFLAGS = -O2 $(ACHK) $(DP)
+
+ all: $(PROGS)
+
+ install: $(PROGS)
+- $(INSTALLCMD) $(PROGS) $(BINDIR)
++ install -d -m 0755 $(BINDIR)
++ install -m 0755 $(PROGS) $(BINDIR)
+
+ clean:
+ -/bin/rm $(PROGS)
+@@ -114,7 +48,6 @@
+
+ avl: $(AOBJS)
+ $(FC) -o avl $(AOBJS) $(ALIBS) $(PLTOBJ) $(EIGOBJ) $(PLTLIB) $(FTNLIB)
+- $(INSTALLCMD) avl $(BINDIR)
+
+ dtest: dtest.o
+ $(FC) -o dtest dtest.o
diff --git a/academic/avl/Makefile_patches/Makefile.eispack.patch b/academic/avl/Makefile_patches/Makefile.eispack.patch
new file mode 100644
index 0000000000..eb6aee7ef0
--- /dev/null
+++ b/academic/avl/Makefile_patches/Makefile.eispack.patch
@@ -0,0 +1,28 @@
+--- eispack/Makefile 2013-10-06 19:33:49.000000000 -0400
++++ eispack/Makefile.eispack 2016-09-11 19:26:35.000000000 -0400
+@@ -1,14 +1,10 @@
+-
+ FC = gfortran
+-FLG = -O
++FLG = -O2
+ AR = ar r
+ RAN = ranlib
+
+-DP =
+-EISLIB = eispack_gSP.a
+-
+-#DP = -fdefault-real-8
+-#EISLIB = eispack_gDP.a
++DP = -fdefault-real-8
++EISLIB = eispack_gDP.a
+
+
+ $(EISLIB): eispack.f
+@@ -17,6 +13,5 @@
+ $(RAN) $(EISLIB)
+
+ clean:
+- /bin/rm *.o *.a
+-
++ rm *.o *.a
+
diff --git a/academic/avl/Makefile_patches/config.make.plotlib.patch b/academic/avl/Makefile_patches/config.make.plotlib.patch
new file mode 100644
index 0000000000..991c2f0b3e
--- /dev/null
+++ b/academic/avl/Makefile_patches/config.make.plotlib.patch
@@ -0,0 +1,25 @@
+--- plotlib/config.make 2013-10-06 19:32:13.000000000 -0400
++++ plotlib/config.make.plotlib 2016-09-11 21:45:12.000000000 -0400
+@@ -7,7 +7,7 @@
+
+
+ # Set library name
+-PLTLIB = libPlt_gSP.a
++PLTLIB = libPlt_gDP.a
+
+ # Some fortrans need trailing underscores in C interface symbols (see Xwin.c)
+ # This should work for most of the "unix" fortran compilers
+@@ -15,10 +15,10 @@
+
+ FC = gfortran
+ CC = gcc
+-#DP = -fdefault-real-8
++DP = -fdefault-real-8
+
+-FFLAGS = -m64 -O2 $(DP)
+-CFLAGS = -m64 -O2 $(DEFINE) -I/usr/X11/include
++FFLAGS = -O2 $(DP)
++CFLAGS = -O2 $(DEFINE) -I/usr/X11/include
+ AR = ar r
+ RANLIB = ranlib
+ LINKLIB = -L/usr/X11R6/lib -lX11