summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-09 17:18:41 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-09 17:18:41 +0700
commit6716ba8e5b4335d50aee74cae6a73ae8cd64b359 (patch)
tree897814fb84206ecb58c1fb9d425af65896327e31
parent604f8c4db2c1d4d6c781ab3d37e072f6a981787b (diff)
downloadslackbuilds-6716ba8e5b4335d50aee74cae6a73ae8cd64b359.tar.gz
python/planes: Removed.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/planes/README9
-rw-r--r--python/planes/planes.SlackBuild81
-rw-r--r--python/planes/planes.info10
-rw-r--r--python/planes/slack-desc19
4 files changed, 0 insertions, 119 deletions
diff --git a/python/planes/README b/python/planes/README
deleted file mode 100644
index 1cef88d882..0000000000
--- a/python/planes/README
+++ /dev/null
@@ -1,9 +0,0 @@
-planes is a hierarchical surface framework for PyGame by Florian Berger.
-
-The planes module introduces the "Plane" class which extends PyGame's
-"Surface" functionality, offering a hierarchy of mouse-sensitive, draggable
-Surfaces that can be used as sprites, windows, icons or other interactive
-elements.
-
-In addition, the planes.gui module uses planes to provide basic GUI
-elements like container, label, text box, option list and button.
diff --git a/python/planes/planes.SlackBuild b/python/planes/planes.SlackBuild
deleted file mode 100644
index 9e2c6b3cbf..0000000000
--- a/python/planes/planes.SlackBuild
+++ /dev/null
@@ -1,81 +0,0 @@
-#!/bin/bash
-# Slackware build script for planes
-# Copyright 2013 Klaatu klaatu@member.fsf.org
-#
-# GNU All-Permissive License
-# Copying and distribution of this file, with or without modification,
-# are permitted in any medium without royalty provided the copyright
-# notice and this notice are preserved. This file is offered as-is,
-# without any warranty.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=planes
-VERSION=${VERSION:-0.6.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-unzip $CWD/$PRGNAM-$VERSION.zip -d $TMP
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/planes/planes.info b/python/planes/planes.info
deleted file mode 100644
index 802ea1bc2d..0000000000
--- a/python/planes/planes.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="planes"
-VERSION="0.6.0"
-HOMEPAGE="http://florian-berger.de/en/software/planes"
-DOWNLOAD="http://static.florian-berger.de/planes-0.6.0.zip"
-MD5SUM="3cd067054cc88913ed3541cf30c060a3"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="pygame"
-MAINTAINER="klaatu"
-EMAIL="klaatu@member.fsf.org"
diff --git a/python/planes/slack-desc b/python/planes/slack-desc
deleted file mode 100644
index f9a81c7663..0000000000
--- a/python/planes/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-planes: planes (surface framework for Pygame)
-planes:
-planes: The planes module introduces the "Plane" class which extends PyGame's
-planes: "Surface" functionality, offering a hierarchy of mouse-sensitive,
-planes: draggable Surfaces that can be used as sprites, windows, icons or
-planes: other interactive elements.
-planes:
-planes: Compatible with Python 2.x and Python 3.x
-planes:
-planes:
-planes: