summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Trigona-Harany <slackbuilds@jaxartes.net>2021-04-10 09:39:56 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-04-10 09:39:56 +0700
commita2d71690b88d69831e50290030af03eca6e04fd6 (patch)
tree8ad12a99221afa1fe9cc7b9eec31fde86b751cc0
parent0f4246fca49f7fbba757a5fa39ec07e256f2b92b (diff)
downloadslackbuilds-a2d71690b88d69831e50290030af03eca6e04fd6.tar.gz
python/nest_asyncio: Added (nested async event loops).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/nest_asyncio/README10
-rw-r--r--python/nest_asyncio/nest_asyncio.SlackBuild87
-rw-r--r--python/nest_asyncio/nest_asyncio.info10
-rw-r--r--python/nest_asyncio/slack-desc18
4 files changed, 125 insertions, 0 deletions
diff --git a/python/nest_asyncio/README b/python/nest_asyncio/README
new file mode 100644
index 0000000000..212658bb31
--- /dev/null
+++ b/python/nest_asyncio/README
@@ -0,0 +1,10 @@
+By design asyncio does not allow its event loop to be nested. This presents a
+practical problem: When in an environment where the event loop is already
+running it's impossible to run tasks and wait for the result. Trying to do so
+will give the error "RuntimeError: This event loop is already running".
+
+The issue pops up in various environments, such as web servers, GUI
+applications and in Jupyter notebooks.
+
+This module patches asyncio to allow nested use of asyncio.run and
+loop.run_until_complete.
diff --git a/python/nest_asyncio/nest_asyncio.SlackBuild b/python/nest_asyncio/nest_asyncio.SlackBuild
new file mode 100644
index 0000000000..64607ec277
--- /dev/null
+++ b/python/nest_asyncio/nest_asyncio.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for nest_asyncio
+
+# Copyright 2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=nest_asyncio
+VERSION=${VERSION:-1.5.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/nest_asyncio/nest_asyncio.info b/python/nest_asyncio/nest_asyncio.info
new file mode 100644
index 0000000000..8286b6e43b
--- /dev/null
+++ b/python/nest_asyncio/nest_asyncio.info
@@ -0,0 +1,10 @@
+PRGNAM="nest_asyncio"
+VERSION="1.5.1"
+HOMEPAGE="https://github.com/erdewit/nest_asyncio"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/n/nest_asyncio/nest_asyncio-1.5.1.tar.gz"
+MD5SUM="6271f5e4181736c2e711657ef1eae915"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/nest_asyncio/slack-desc b/python/nest_asyncio/slack-desc
new file mode 100644
index 0000000000..4b9f869fc5
--- /dev/null
+++ b/python/nest_asyncio/slack-desc
@@ -0,0 +1,18 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+nest_asyncio: nest_asyncio (nested async event loops)
+nest_asyncio:
+nest_asyncio: This module patches asyncio to allow nested use of asyncio.run and
+nest_asyncio: loop.run_until_complete.
+nest_asyncio:
+nest_asyncio:
+nest_asyncio:
+nest_asyncio:
+nest_asyncio:
+nest_asyncio: