summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukenShiro <lukenshiro@ngi.it>2011-11-01 08:40:58 -0200
committerNiels Horn <niels.horn@slackbuilds.org>2011-11-01 08:40:58 -0200
commit5331682a26ab2104f07e1dcc45a6857ac9773b01 (patch)
tree95c2d56b83f33f12b7bcd9ecf3f59320e6df4153
parente885adb06d5713b43bb51a872f644f44de2ca624 (diff)
downloadslackbuilds-5331682a26ab2104f07e1dcc45a6857ac9773b01.tar.gz
python/pyflakes: Updated for version 0.5.0 (+new category)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
-rw-r--r--python/pyflakes/README (renamed from development/pyflakes/README)7
-rw-r--r--python/pyflakes/pyflakes.SlackBuild (renamed from development/pyflakes/pyflakes.SlackBuild)13
-rw-r--r--python/pyflakes/pyflakes.info (renamed from development/pyflakes/pyflakes.info)8
-rw-r--r--python/pyflakes/slack-desc (renamed from development/pyflakes/slack-desc)2
4 files changed, 16 insertions, 14 deletions
diff --git a/development/pyflakes/README b/python/pyflakes/README
index 60e7585433..ffc04d348b 100644
--- a/development/pyflakes/README
+++ b/python/pyflakes/README
@@ -10,7 +10,8 @@ The two primary categories of defects reported by PyFlakes are:
* Names which are redefined without having been used
These can each take many forms. For example, PyFlakes will tell you when
-you have forgotten an import, mistyped a variable name, defined two functions
-with the same name, shadowed a variable from another scope, imported a module
-twice, or two different modules with the same name, and so on.
+you have forgotten an import, mistyped a variable name, defined two
+functions with the same name, shadowed a variable from another scope,
+imported a module twice, or two different modules with the same name, and
+so on.
diff --git a/development/pyflakes/pyflakes.SlackBuild b/python/pyflakes/pyflakes.SlackBuild
index 01284f8684..7c530c1ee7 100644
--- a/development/pyflakes/pyflakes.SlackBuild
+++ b/python/pyflakes/pyflakes.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pyflakes
-# Copyright 2010 LukenShiro <lukenshiro@ngi.it>
+# Copyright 2010-2011 LukenShiro <lukenshiro@ngi.it>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,16 +23,14 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pyflakes
-VERSION=${VERSION:-0.4.0}
+VERSION=${VERSION:-0.5.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -53,12 +51,15 @@ rm -rf $PRGNAM-$VERSION
tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
python setup.py build
python setup.py install --prefix=/usr/ --root=$PKG
-# Copy documentation files
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/development/pyflakes/pyflakes.info b/python/pyflakes/pyflakes.info
index d1b512bb5f..797606a16b 100644
--- a/development/pyflakes/pyflakes.info
+++ b/python/pyflakes/pyflakes.info
@@ -1,10 +1,10 @@
PRGNAM="pyflakes"
-VERSION="0.4.0"
+VERSION="0.5.0"
HOMEPAGE="http://www.divmod.org/trac/wiki/DivmodPyflakes"
-DOWNLOAD="http://pypi.python.org/packages/source/p/pyflakes/pyflakes-0.4.0.tar.gz"
-MD5SUM="630a72510aae8758f48cf60e4fa17176"
+DOWNLOAD="http://pypi.python.org/packages/source/p/pyflakes/pyflakes-0.5.0.tar.gz"
+MD5SUM="568dab27c42e5822787aa8a603898672"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="LukenShiro"
EMAIL="lukenshiro@ngi.it"
-APPROVED="dsomero"
+APPROVED="Niels Horn"
diff --git a/development/pyflakes/slack-desc b/python/pyflakes/slack-desc
index 7cbf59ab9f..747587f819 100644
--- a/development/pyflakes/slack-desc
+++ b/python/pyflakes/slack-desc
@@ -5,7 +5,7 @@
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
- |-----handy-ruler--------------------------------------------------------|
+ |-----handy-ruler------------------------------------------------------|
pyflakes: pyflakes (passive checker of Python programs)
pyflakes:
pyflakes: Pyflakes is a program to analyze Python programs and detect various