summaryrefslogtreecommitdiff
path: root/calendar/installer/windows/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'calendar/installer/windows/Makefile.in')
-rw-r--r--calendar/installer/windows/Makefile.in86
1 files changed, 0 insertions, 86 deletions
diff --git a/calendar/installer/windows/Makefile.in b/calendar/installer/windows/Makefile.in
deleted file mode 100644
index 833a941e4..000000000
--- a/calendar/installer/windows/Makefile.in
+++ /dev/null
@@ -1,86 +0,0 @@
-# This Source Code Form is subject to the terms of the Mozilla Public
-# License, v. 2.0. If a copy of the MPL was not distributed with this
-# file, You can obtain one at http://mozilla.org/MPL/2.0/.
-
-DEPTH = @DEPTH@
-topsrcdir = @top_srcdir@
-srcdir = @srcdir@
-VPATH = @srcdir@
-
-include $(DEPTH)/config/autoconf.mk
-
-include $(MOZILLA_SRCDIR)/system/installer/package-name.mk
-
-CONFIG_DIR = instgen
-SFX_MODULE = $(topsrcdir)/other-licenses/7zstub/sunbird/7zSD.sfx
-
-ifdef MOZ_UPDATER
-DEFINES += -DMOZ_UPDATER=1
-endif
-
-PP_LOCALIZED_FILES = \
- packages-static \
- $(NULL)
-
-INSTALLER_FILES = \
- app.tag \
- nsis/installer.nsi \
- nsis/uninstaller.nsi \
- nsis/shared.nsh \
- $(NULL)
-
-BRANDING_FILES = \
- branding.nsi \
- wizHeader.bmp \
- wizHeaderRTL.bmp \
- wizWatermark.bmp \
- $(NULL)
-
-DEFINES += \
- -DAB_CD=$(AB_CD) \
- -DPKG_BASENAME=$(PKG_BASENAME) \
- -DMOZ_APP_VERSION=$(MOZ_APP_VERSION) \
- -DMOZ_APP_DISPLAYNAME=${MOZ_APP_DISPLAYNAME} \
- -DMOZILLA_VERSION=${MOZILLA_VERSION} \
- $(NULL)
-
-include $(topsrcdir)/config/config.mk
-
-installer::
- $(MAKE) -C .. installer-stage
- $(MAKE) $(CONFIG_DIR)/setup.exe
-
-# For building the uninstaller during the application build so it can be
-# included for mar file generation.
-uninstaller::
- $(RM) -rf $(CONFIG_DIR) && mkdir $(CONFIG_DIR)
- $(INSTALL) $(addprefix $(srcdir)/,$(INSTALLER_FILES)) $(CONFIG_DIR)
- $(INSTALL) $(addprefix $(DIST)/branding/,$(BRANDING_FILES)) $(CONFIG_DIR)
- $(EXIT_ON_ERROR) \
- for i in $(PP_LOCALIZED_FILES); do \
- $(PYTHON) $(MOZILLA_SRCDIR)/config/Preprocessor.py $(DEFINES) $(ACDEFINES) $(srcdir)/$$i > $(CONFIG_DIR)/$$i; \
- done
- $(PYTHON) $(MOZILLA_SRCDIR)/config/Preprocessor.py -Fsubstitution $(DEFINES) $(ACDEFINES) \
- $(srcdir)/nsis/defines.nsi.in > $(CONFIG_DIR)/defines.nsi
- $(PYTHON) $(MOZILLA_SRCDIR)/system/installer/windows/nsis/preprocess-locale.py \
- --preprocess-locale $(MOZILLA_SRCDIR) \
- $(call EXPAND_LOCALE_SRCDIR,calendar/locales)/installer $(AB_CD) $(CONFIG_DIR)
-
-$(CONFIG_DIR)/setup.exe::
- $(RM) -rf $(CONFIG_DIR) && mkdir $(CONFIG_DIR)
- $(INSTALL) $(addprefix $(srcdir)/,$(INSTALLER_FILES)) $(CONFIG_DIR)
- $(INSTALL) $(addprefix $(DIST)/branding/,$(BRANDING_FILES)) $(CONFIG_DIR)
- $(PYTHON) $(MOZILLA_SRCDIR)/system/installer/windows/nsis/preprocess-locale.py \
- --convert-utf8-utf16le $(DIST)/branding/license.txt $(CONFIG_DIR)/license.txt
- $(EXIT_ON_ERROR) \
- for i in $(PP_LOCALIZED_FILES); do \
- $(PYTHON) $(MOZILLA_SRCDIR)/config/Preprocessor.py $(DEFINES) $(ACDEFINES) $(srcdir)/$$i > $(CONFIG_DIR)/$$i; \
- done
- $(PYTHON) $(MOZILLA_SRCDIR)/config/Preprocessor.py -Fsubstitution $(DEFINES) $(ACDEFINES) \
- $(srcdir)/nsis/defines.nsi.in > $(CONFIG_DIR)/defines.nsi
- $(PYTHON) $(MOZILLA_SRCDIR)/system/installer/windows/nsis/preprocess-locale.py \
- --preprocess-locale $(MOZILLA_SRCDIR) \
- $(call EXPAND_LOCALE_SRCDIR,calendar/locales)/installer $(AB_CD) $(CONFIG_DIR)
-
-include $(topsrcdir)/config/rules.mk
-include $(MOZILLA_SRCDIR)/system/installer/windows/nsis/makensis.mk