summaryrefslogtreecommitdiff
path: root/build/macosx
diff options
context:
space:
mode:
Diffstat (limited to 'build/macosx')
-rw-r--r--build/macosx/cross-mozconfig.common47
-rw-r--r--build/macosx/local-mozconfig.common46
-rw-r--r--build/macosx/mozconfig.common5
-rw-r--r--build/macosx/universal/check-sync-exceptions9
-rw-r--r--build/macosx/universal/flight.mk33
-rw-r--r--build/macosx/universal/mozconfig11
-rw-r--r--build/macosx/universal/mozconfig.common54
7 files changed, 0 insertions, 205 deletions
diff --git a/build/macosx/cross-mozconfig.common b/build/macosx/cross-mozconfig.common
deleted file mode 100644
index 8e56394d0..000000000
--- a/build/macosx/cross-mozconfig.common
+++ /dev/null
@@ -1,47 +0,0 @@
-# This Source Code Form is subject to the terms of the Mozilla Public
-# License, v. 2.0. If a copy of the MPL was not distributed with this
-# file, You can obtain one at http://mozilla.org/MPL/2.0/.
-
-MOZ_AUTOMATION_L10N_CHECK=0
-
-if [ "x$IS_NIGHTLY" = "xyes" ]; then
- # Some nightlies (eg: Mulet) don't want these set.
- MOZ_AUTOMATION_UPDATE_PACKAGING=${MOZ_AUTOMATION_UPDATE_PACKAGING-1}
- MOZ_AUTOMATION_SDK=${MOZ_AUTOMATION_SDK-1}
-fi
-. "$topsrcdir/build/mozconfig.common"
-
-# ld needs libLTO.so from llvm
-mk_add_options "export LD_LIBRARY_PATH=$topsrcdir/clang/lib"
-
-CROSS_CCTOOLS_PATH=$topsrcdir/cctools
-CROSS_SYSROOT=$topsrcdir/MacOSX10.7.sdk
-CROSS_PRIVATE_FRAMEWORKS=$CROSS_SYSROOT/System/Library/PrivateFrameworks
-FLAGS="-target x86_64-apple-darwin10 -mlinker-version=136 -B $CROSS_CCTOOLS_PATH/bin -isysroot $CROSS_SYSROOT"
-
-export CC="$topsrcdir/clang/bin/clang $FLAGS"
-export CXX="$topsrcdir/clang/bin/clang++ $FLAGS"
-export CPP="$topsrcdir/clang/bin/clang $FLAGS -E"
-export LLVMCONFIG=$topsrcdir/clang/bin/llvm-config
-export LDFLAGS="-Wl,-syslibroot,$CROSS_SYSROOT -Wl,-dead_strip"
-export TOOLCHAIN_PREFIX=$CROSS_CCTOOLS_PATH/bin/x86_64-apple-darwin10-
-export DSYMUTIL=$topsrcdir/clang/bin/llvm-dsymutil
-export GENISOIMAGE=$topsrcdir/genisoimage/genisoimage
-export DMG_TOOL=$topsrcdir/dmg/dmg
-
-export HOST_CC="$topsrcdir/clang/bin/clang"
-export HOST_CXX="$topsrcdir/clang/bin/clang++"
-export HOST_CPP="$topsrcdir/clang/bin/clang -E"
-export HOST_CFLAGS="-g"
-export HOST_CXXFLAGS="-g"
-export HOST_LDFLAGS="-g"
-
-ac_add_options --target=x86_64-apple-darwin
-ac_add_options --with-macos-private-frameworks=$CROSS_PRIVATE_FRAMEWORKS
-
-# Enable static analysis checks by default on OSX cross builds.
-ac_add_options --enable-clang-plugin
-
-. "$topsrcdir/build/mozconfig.cache"
-
-export SOCORRO_SYMBOL_UPLOAD_TOKEN_FILE=/builds/crash-stats-api.token
diff --git a/build/macosx/local-mozconfig.common b/build/macosx/local-mozconfig.common
deleted file mode 100644
index 02a09d2fe..000000000
--- a/build/macosx/local-mozconfig.common
+++ /dev/null
@@ -1,46 +0,0 @@
-# This Source Code Form is subject to the terms of the Mozilla Public
-# License, v. 2.0. If a copy of the MPL was not distributed with this
-# file, You can obtain one at http://mozilla.org/MPL/2.0/.
-
-if [ "x$IS_NIGHTLY" = "xyes" ]; then
- # Some nightlies (eg: Mulet) don't want these set.
- MOZ_AUTOMATION_UPLOAD_SYMBOLS=${MOZ_AUTOMATION_UPLOAD_SYMBOLS-1}
- MOZ_AUTOMATION_UPDATE_PACKAGING=${MOZ_AUTOMATION_UPDATE_PACKAGING-1}
- MOZ_AUTOMATION_SDK=${MOZ_AUTOMATION_SDK-1}
-fi
-. "$topsrcdir/build/mozconfig.common"
-
-if [ -d "$topsrcdir/clang" ]; then
- # mozilla-central based build
- export CC=$topsrcdir/clang/bin/clang
- export CXX=$topsrcdir/clang/bin/clang++
- export LLVMCONFIG=$topsrcdir/clang/bin/llvm-config
- export DSYMUTIL=$topsrcdir/clang/bin/llvm-dsymutil
- # Use an updated linker.
- ldflags="-B$topsrcdir/cctools/bin"
-elif [ -d "$topsrcdir/../clang" ]; then
- # comm-central based build
- export CC=$topsrcdir/../clang/bin/clang
- export CXX=$topsrcdir/../clang/bin/clang++
- export LLVMCONFIG=$topsrcdir/../clang/bin/llvm-config
- export DSYMUTIL=$topsrcdir/../clang/bin/llvm-dsymutil
- # Use an updated linker.
- ldflags="-B$topsrcdir/../cctools/bin"
-fi
-
-# Ensure the updated linker doesn't generate things our older build tools
-# don't understand.
-ldflags="$ldflags -Wl,-no_data_in_code_info"
-export LDFLAGS="$ldflags"
-
-# If not set use the system default clang
-if [ -z "$CC" ]; then
- export CC=clang
-fi
-
-# If not set use the system default clang++
-if [ -z "$CXX" ]; then
- export CXX=clang++
-fi
-
-export SOCORRO_SYMBOL_UPLOAD_TOKEN_FILE=/builds/crash-stats-api.token
diff --git a/build/macosx/mozconfig.common b/build/macosx/mozconfig.common
deleted file mode 100644
index 27634b7f3..000000000
--- a/build/macosx/mozconfig.common
+++ /dev/null
@@ -1,5 +0,0 @@
-if test `uname -s` = Linux; then
- . $topsrcdir/build/macosx/cross-mozconfig.common
-else
- . $topsrcdir/build/macosx/local-mozconfig.common
-fi
diff --git a/build/macosx/universal/check-sync-exceptions b/build/macosx/universal/check-sync-exceptions
deleted file mode 100644
index fc5149281..000000000
--- a/build/macosx/universal/check-sync-exceptions
+++ /dev/null
@@ -1,9 +0,0 @@
-flight.mk
-mozconfig.common
-
-# Ignore detritus left lying around by editing tools.
-*~
-.#*
-#*#
-*.orig
-*.rej
diff --git a/build/macosx/universal/flight.mk b/build/macosx/universal/flight.mk
deleted file mode 100644
index 2b79ef7ae..000000000
--- a/build/macosx/universal/flight.mk
+++ /dev/null
@@ -1,33 +0,0 @@
-# This Source Code Form is subject to the terms of the Mozilla Public
-# License, v. 2.0. If a copy of the MPL was not distributed with this
-# file, You can obtain one at http://mozilla.org/MPL/2.0/.
-
-# BE CAREFUL! This makefile handles a postflight_all rule for a
-# multi-project build, so DON'T rely on anything that might differ between
-# the two OBJDIRs.
-
-ifndef OBJDIR
-OBJDIR_ARCH_1 = $(MOZ_OBJDIR)/$(firstword $(MOZ_BUILD_PROJECTS))
-OBJDIR_ARCH_2 = $(MOZ_OBJDIR)/$(word 2,$(MOZ_BUILD_PROJECTS))
-DIST_ARCH_1 = $(OBJDIR_ARCH_1)/dist
-DIST_ARCH_2 = $(OBJDIR_ARCH_2)/dist
-DIST_UNI = $(DIST_ARCH_1)/universal
-OBJDIR = $(OBJDIR_ARCH_1)
-endif
-
-topsrcdir = $(TOPSRCDIR)
-DEPTH = $(OBJDIR)
-include $(OBJDIR)/config/autoconf.mk
-
-core_abspath = $(if $(filter /%,$(1)),$(1),$(CURDIR)/$(1))
-
-DIST = $(OBJDIR)/dist
-
-postflight_all:
- mkdir -p $(DIST_UNI)/$(MOZ_PKG_APPNAME)
- rm -f $(DIST_ARCH_2)/universal
- ln -s $(abspath $(DIST_UNI)) $(DIST_ARCH_2)/universal
-# Stage a package for buildsymbols to be happy. Doing so in OBJDIR_ARCH_1
-# actually does a universal staging with both OBJDIR_ARCH_1 and OBJDIR_ARCH_2.
- $(MAKE) -C $(OBJDIR_ARCH_1)/$(subst ../,,$(MOZ_BUILD_APP))/installer \
- PKG_SKIP_STRIP=1 stage-package
diff --git a/build/macosx/universal/mozconfig b/build/macosx/universal/mozconfig
deleted file mode 100644
index 32ab66f2d..000000000
--- a/build/macosx/universal/mozconfig
+++ /dev/null
@@ -1,11 +0,0 @@
-# This Source Code Form is subject to the terms of the Mozilla Public
-# License, v. 2.0. If a copy of the MPL was not distributed with this
-# file, You can obtain one at http://mozilla.org/MPL/2.0/.
-
-# i386/x86-64 Universal Build mozconfig
-
-# As used here, arguments in $MOZ_BUILD_PROJECTS are suitable as arguments
-# to gcc's -arch parameter.
-mk_add_options MOZ_BUILD_PROJECTS="x86_64 i386"
-
-. $topsrcdir/build/macosx/universal/mozconfig.common
diff --git a/build/macosx/universal/mozconfig.common b/build/macosx/universal/mozconfig.common
deleted file mode 100644
index 518274b51..000000000
--- a/build/macosx/universal/mozconfig.common
+++ /dev/null
@@ -1,54 +0,0 @@
-# This Source Code Form is subject to the terms of the Mozilla Public
-# License, v. 2.0. If a copy of the MPL was not distributed with this
-# file, You can obtain one at http://mozilla.org/MPL/2.0/.
-
-mk_add_options MOZ_UNIFY_BDATE=1
-
-mk_add_options MOZ_POSTFLIGHT_ALL+=build/macosx/universal/flight.mk
-
-DARWIN_VERSION=`uname -r`
-ac_add_app_options i386 --target=i386-apple-darwin$DARWIN_VERSION
-ac_add_app_options x86_64 --target=x86_64-apple-darwin$DARWIN_VERSION
-ac_add_app_options i386 --with-unify-dist=../x86_64/dist
-ac_add_app_options x86_64 --with-unify-dist=../i386/dist
-
-ac_add_options --with-macos-sdk=/Developer/SDKs/MacOSX10.7.sdk
-
-. $topsrcdir/build/macosx/mozconfig.common
-
-# $MOZ_BUILD_APP is only defined when sourced by configure. That's not a
-# problem, because the variables it affects only need to be set for
-# configure.
-if test -n "$MOZ_BUILD_APP" ; then
-if test "$MOZ_BUILD_APP" = "i386" -o "$MOZ_BUILD_APP" = "x86_64"; then
- TARGET_CPU=$MOZ_BUILD_APP
-
- # $HOST_CXX is presently unused. $HOST_CC will only be used during a cross
- # compile.
- HOST_CC=$CC
- HOST_CXX=$CXX
-
- NATIVE_CPU=`$topsrcdir/build/autoconf/config.guess | cut -f1 -d-`
-
- # It's not strictly necessary to specify -arch during native builds, but it
- # makes the merged about:buildconfig easier to follow, and it reduces
- # conditionalized differences between builds.
- CC="$CC -arch $TARGET_CPU"
- CXX="$CXX -arch $TARGET_CPU"
-
- # These must be set for cross builds, and don't hurt straight builds.
- RANLIB=ranlib
- AR=ar
- AS=$CC
- LD=ld
- STRIP="strip"
- OTOOL="otool"
-
- # Each per-CPU build should be entirely oblivious to the fact that a
- # universal binary will be produced. The exception is packager.mk, which
- # needs to know to look for universal bits when building the .dmg.
- UNIVERSAL_BINARY=1
-
- export CC CXX HOST_CC HOST_CXX RANLIB AR AS LD STRIP OTOOL
-fi
-fi