summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--components/gservice/moz.build1
-rw-r--r--components/gservice/src/nsGIOProtocolHandler.cpp (renamed from extensions/gio/nsGIOProtocolHandler.cpp)0
-rw-r--r--extensions/gio/moz.build12
-rw-r--r--old-configure.in10
-rw-r--r--system/toolkit.mozbuild3
5 files changed, 1 insertions, 25 deletions
diff --git a/components/gservice/moz.build b/components/gservice/moz.build
index b57567241..8371b94b8 100644
--- a/components/gservice/moz.build
+++ b/components/gservice/moz.build
@@ -16,6 +16,7 @@ if CONFIG['MOZ_ENABLE_GCONF']:
if CONFIG['MOZ_ENABLE_GIO']:
SOURCES += [
+ 'src/nsGIOProtocolHandler.cpp',
'src/nsGIOService.cpp',
'src/nsGSettingsService.cpp',
'src/nsPackageKitService.cpp'
diff --git a/extensions/gio/nsGIOProtocolHandler.cpp b/components/gservice/src/nsGIOProtocolHandler.cpp
index a378e8700..a378e8700 100644
--- a/extensions/gio/nsGIOProtocolHandler.cpp
+++ b/components/gservice/src/nsGIOProtocolHandler.cpp
diff --git a/extensions/gio/moz.build b/extensions/gio/moz.build
deleted file mode 100644
index 94e806f1c..000000000
--- a/extensions/gio/moz.build
+++ /dev/null
@@ -1,12 +0,0 @@
-# -*- Mode: python; indent-tabs-mode: nil; tab-width: 40 -*-
-# This Source Code Form is subject to the terms of the Mozilla Public
-# License, v. 2.0. If a copy of the MPL was not distributed with this
-# file, You can obtain one at http://mozilla.org/MPL/2.0/.
-
-SOURCES += [
- 'nsGIOProtocolHandler.cpp',
-]
-
-FINAL_LIBRARY = 'xul'
-
-CXXFLAGS += CONFIG['MOZ_GIO_CFLAGS']
diff --git a/old-configure.in b/old-configure.in
index 4b32f8909..ed4946744 100644
--- a/old-configure.in
+++ b/old-configure.in
@@ -3139,19 +3139,9 @@ MOZ_ARG_ENABLE_STRING(extensions,
done],
MOZ_EXTENSIONS="$MOZ_EXTENSIONS_DEFAULT")
-if test -z "$MOZ_ENABLE_GIO" -a `echo "$MOZ_EXTENSIONS" | grep -c gio` -ne 0; then
- # Suppress warning on non-X11 platforms
- if test -n "$MOZ_X11"; then
- AC_MSG_WARN([Removing gio from MOZ_EXTENSIONS due to --disable-gio.])
- fi
- MOZ_EXTENSIONS=`echo $MOZ_EXTENSIONS | sed -e 's|gio||'`
-fi
-
if test `echo "$MOZ_EXTENSIONS" | grep -c gio` -ne 0; then
- MOZ_GIO_COMPONENT=1
MOZ_EXTENSIONS=`echo $MOZ_EXTENSIONS | sed -e 's|gio||'`
fi
-AC_SUBST(MOZ_GIO_COMPONENT)
dnl Ensure every extension exists, to avoid mostly-inscrutable error messages
dnl when trying to build a nonexistent extension.
diff --git a/system/toolkit.mozbuild b/system/toolkit.mozbuild
index 89a8840ec..c52283179 100644
--- a/system/toolkit.mozbuild
+++ b/system/toolkit.mozbuild
@@ -66,9 +66,6 @@ if CONFIG['MOZ_PREF_EXTENSIONS']:
DIRS += ['/services']
-if CONFIG['MOZ_GIO_COMPONENT']:
- DIRS += ['/extensions/gio']
-
DIRS += [
'/system/evil/StaticXULComponentsEnd',
'/system/evil',