summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gfx/2d/DrawTargetCairo.cpp14
-rw-r--r--gfx/thebes/gfxASurface.cpp9
-rw-r--r--libs/cairo/src/cairo-features.h.in6
-rw-r--r--libs/cairo/src/cairo-supported-features.h2
-rw-r--r--libs/cairo/src/cairoint.h13
-rw-r--r--old-configure.in8
6 files changed, 1 insertions, 51 deletions
diff --git a/gfx/2d/DrawTargetCairo.cpp b/gfx/2d/DrawTargetCairo.cpp
index 2fac703ee..13283ab4c 100644
--- a/gfx/2d/DrawTargetCairo.cpp
+++ b/gfx/2d/DrawTargetCairo.cpp
@@ -23,10 +23,6 @@
#include "Logging.h"
#include "Tools.h"
-#ifdef CAIRO_HAS_QUARTZ_SURFACE
-#include "cairo-quartz.h"
-#endif
-
#ifdef CAIRO_HAS_XLIB_SURFACE
#include "cairo-xlib.h"
#include "cairo-xlib-xrender.h"
@@ -163,10 +159,6 @@ SupportsSelfCopy(cairo_surface_t* surface)
{
switch (cairo_surface_get_type(surface))
{
-#ifdef CAIRO_HAS_QUARTZ_SURFACE
- case CAIRO_SURFACE_TYPE_QUARTZ:
- return true;
-#endif
#ifdef CAIRO_HAS_WIN32_SURFACE
case CAIRO_SURFACE_TYPE_WIN32:
case CAIRO_SURFACE_TYPE_WIN32_PRINTING:
@@ -1848,12 +1840,6 @@ DrawTargetCairo::CreateSimilarDrawTarget(const IntSize &aSize, SurfaceFormat aFo
GfxFormatToCairoFormat(aFormat), aSize.width, aSize.height);
break;
#endif
-#ifdef CAIRO_HAS_QUARTZ_SURFACE
- case CAIRO_SURFACE_TYPE_QUARTZ:
- similar = cairo_quartz_surface_create_cg_layer(
- mSurface, GfxFormatToCairoContent(aFormat), aSize.width, aSize.height);
- break;
-#endif
default:
similar = cairo_surface_create_similar(mSurface,
GfxFormatToCairoContent(aFormat),
diff --git a/gfx/thebes/gfxASurface.cpp b/gfx/thebes/gfxASurface.cpp
index 31f185596..0e94ef0be 100644
--- a/gfx/thebes/gfxASurface.cpp
+++ b/gfx/thebes/gfxASurface.cpp
@@ -33,10 +33,6 @@
#include "gfxXlibSurface.h"
#endif
-#ifdef CAIRO_HAS_QUARTZ_SURFACE
-#include "gfxQuartzSurface.h"
-#endif
-
#include <stdio.h>
#include <limits.h>
@@ -165,11 +161,6 @@ gfxASurface::Wrap (cairo_surface_t *csurf, const IntSize& aSize)
result = new gfxXlibSurface(csurf);
}
#endif
-#ifdef CAIRO_HAS_QUARTZ_SURFACE
- else if (stype == CAIRO_SURFACE_TYPE_QUARTZ) {
- result = new gfxQuartzSurface(csurf, aSize);
- }
-#endif
else {
result = new gfxUnknownSurface(csurf, aSize);
}
diff --git a/libs/cairo/src/cairo-features.h.in b/libs/cairo/src/cairo-features.h.in
index 9692c7cb7..10e396c9c 100644
--- a/libs/cairo/src/cairo-features.h.in
+++ b/libs/cairo/src/cairo-features.h.in
@@ -33,10 +33,6 @@
@XLIB_XRENDER_SURFACE_FEATURE@
-@QUARTZ_SURFACE_FEATURE@
-
-@QUARTZ_IMAGE_SURFACE_FEATURE@
-
@WIN32_SURFACE_FEATURE@
@OS2_SURFACE_FEATURE@
@@ -53,8 +49,6 @@
@WIN32_D2D_SURFACE_FEATURE@
-@QUARTZ_FONT_FEATURE@
-
@TEE_SURFACE_FEATURE@
@PNG_FUNCTIONS_FEATURE@
diff --git a/libs/cairo/src/cairo-supported-features.h b/libs/cairo/src/cairo-supported-features.h
index aacbab781..61134281e 100644
--- a/libs/cairo/src/cairo-supported-features.h
+++ b/libs/cairo/src/cairo-supported-features.h
@@ -6,8 +6,6 @@
#define CAIRO_HAS_XLIB_SURFACE 1
#define CAIRO_HAS_XLIB_XRENDER_SURFACE 1
-#define CAIRO_HAS_QUARTZ_SURFACE 1
-#define CAIRO_HAS_QUARTZ_FONT 1
#define CAIRO_HAS_WIN32_SURFACE 1
#define CAIRO_HAS_WIN32_FONT 1
#define CAIRO_HAS_PNG_FUNCTIONS 1
diff --git a/libs/cairo/src/cairoint.h b/libs/cairo/src/cairoint.h
index f5dc0da81..31eaf810a 100644
--- a/libs/cairo/src/cairoint.h
+++ b/libs/cairo/src/cairoint.h
@@ -531,12 +531,6 @@ extern const cairo_private struct _cairo_font_face_backend _cairo_dwrite_font_fa
#endif
-#if CAIRO_HAS_QUARTZ_FONT
-
-extern const cairo_private struct _cairo_font_face_backend _cairo_quartz_font_face_backend;
-
-#endif
-
struct _cairo_surface_backend {
cairo_surface_type_t type;
@@ -885,11 +879,6 @@ typedef struct _cairo_traps {
#define CAIRO_FONT_FAMILY_DEFAULT CAIRO_WIN32_FONT_FAMILY_DEFAULT
#define CAIRO_FONT_FACE_BACKEND_DEFAULT &_cairo_win32_font_face_backend
-#elif CAIRO_HAS_QUARTZ_FONT
-
-#define CAIRO_FONT_FAMILY_DEFAULT CAIRO_QUARTZ_FONT_FAMILY_DEFAULT
-#define CAIRO_FONT_FACE_BACKEND_DEFAULT &_cairo_quartz_font_face_backend
-
#elif CAIRO_HAS_FT_FONT
#define CAIRO_FONT_FAMILY_DEFAULT CAIRO_FT_FONT_FAMILY_DEFAULT
@@ -2348,7 +2337,7 @@ cairo_private int
_cairo_ucs4_to_utf8 (uint32_t unicode,
char *utf8);
-#if CAIRO_HAS_WIN32_FONT || CAIRO_HAS_QUARTZ_FONT || CAIRO_HAS_PDF_OPERATORS || CAIRO_HAS_DW_FONT
+#if CAIRO_HAS_WIN32_FONT || CAIRO_HAS_PDF_OPERATORS || CAIRO_HAS_DW_FONT
# define CAIRO_HAS_UTF8_TO_UTF16 1
#endif
#if CAIRO_HAS_UTF8_TO_UTF16
diff --git a/old-configure.in b/old-configure.in
index c0e5dc337..0bfc312a3 100644
--- a/old-configure.in
+++ b/old-configure.in
@@ -4360,11 +4360,6 @@ if test "$MOZ_TREE_CAIRO"; then
fi
case "$MOZ_WIDGET_TOOLKIT" in
- cocoa | uikit)
- QUARTZ_SURFACE_FEATURE="#define CAIRO_HAS_QUARTZ_SURFACE 1"
- QUARTZ_IMAGE_SURFACE_FEATURE="#define CAIRO_HAS_QUARTZ_IMAGE_SURFACE 1"
- QUARTZ_FONT_FEATURE="#define CAIRO_HAS_QUARTZ_FONT 1"
- ;;
windows)
WIN32_D2D_SURFACE_FEATURE="#define CAIRO_HAS_D2D_SURFACE 1"
WIN32_DWRITE_FONT_FEATURE="#define CAIRO_HAS_DWRITE_FONT 1"
@@ -4392,8 +4387,6 @@ if test "$MOZ_TREE_CAIRO"; then
AC_SUBST(SVG_SURFACE_FEATURE)
AC_SUBST(XLIB_SURFACE_FEATURE)
AC_SUBST(XLIB_XRENDER_SURFACE_FEATURE)
- AC_SUBST(QUARTZ_SURFACE_FEATURE)
- AC_SUBST(QUARTZ_IMAGE_SURFACE_FEATURE)
AC_SUBST(WIN32_SURFACE_FEATURE)
AC_SUBST(OS2_SURFACE_FEATURE)
AC_SUBST(DIRECTFB_SURFACE_FEATURE)
@@ -4402,7 +4395,6 @@ if test "$MOZ_TREE_CAIRO"; then
AC_SUBST(WIN32_FONT_FEATURE)
AC_SUBST(WIN32_DWRITE_FONT_FEATURE)
AC_SUBST(WIN32_D2D_SURFACE_FEATURE)
- AC_SUBST(QUARTZ_FONT_FEATURE)
AC_SUBST(PNG_FUNCTIONS_FEATURE)
AC_SUBST(QT_SURFACE_FEATURE)
AC_SUBST(TEE_SURFACE_FEATURE)