summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--aclocal.m41
-rw-r--r--build/autoconf/ios.m4108
-rw-r--r--config/rules.mk4
-rw-r--r--js/src/aclocal.m41
-rw-r--r--js/src/old-configure.in6
-rw-r--r--old-configure.in3
6 files changed, 0 insertions, 123 deletions
diff --git a/aclocal.m4 b/aclocal.m4
index 43ae3a368..f14ddbf29 100644
--- a/aclocal.m4
+++ b/aclocal.m4
@@ -25,7 +25,6 @@ builtin(include, build/autoconf/zlib.m4)dnl
builtin(include, build/autoconf/icu.m4)dnl
builtin(include, build/autoconf/clang-plugin.m4)dnl
builtin(include, build/autoconf/alloc.m4)dnl
-builtin(include, build/autoconf/ios.m4)dnl
builtin(include, build/autoconf/sanitize.m4)dnl
MOZ_PROG_CHECKMSYS()
diff --git a/build/autoconf/ios.m4 b/build/autoconf/ios.m4
deleted file mode 100644
index b341cda89..000000000
--- a/build/autoconf/ios.m4
+++ /dev/null
@@ -1,108 +0,0 @@
-dnl This Source Code Form is subject to the terms of the Mozilla Public
-dnl License, v. 2.0. If a copy of the MPL was not distributed with this
-dnl file, You can obtain one at http://mozilla.org/MPL/2.0/.
-
-AC_DEFUN([MOZ_IOS_PATH_PROG],
-[
-changequote({,})
-_prog_name=ifelse($2, {}, `echo $1 | tr "[:upper:]" "[:lower:]"`, $2)
-changequote([,])
-AC_CACHE_CHECK([for $_prog_name in iOS SDK],
-ac_cv_ios_path_$1,
-[
-_path=`xcrun --sdk $ios_sdk --find $_prog_name 2>/dev/null`
-_res=$?
-if test $_res -ne 0; then
- AC_MSG_ERROR([Could not find '$_prog_name' in the iOS SDK])
-fi
-ac_cv_ios_path_$1=$_path
-])
-$1="${ac_cv_ios_path_$1}$3"
-])
-
-AC_DEFUN([MOZ_IOS_SDK],
-[
-
-MOZ_ARG_WITH_STRING(ios-sdk,
-[ --with-ios-sdk=TYPE
- Type of iOS SDK to use (iphonesimulator, iphoneos)
- and optionally version (like iphoneos8.2)],
- ios_sdk=$withval)
-
-MOZ_ARG_ENABLE_STRING(ios-target,
- [ --enable-ios-target=VER (default=8.0)
- Set the minimum iOS version needed at runtime],
- [_IOS_TARGET=$enableval])
-_IOS_TARGET_DEFAULT=8.0
-
-case "$target" in
-arm*-apple-darwin*)
- if test -z "$ios_sdk" -o "$ios_sdk" = "yes"; then
- ios_sdk=iphoneos
- fi
- case "$ios_sdk" in
- iphoneos*)
- ios_target_arg="-miphoneos-version-min"
- ;;
- *)
- AC_MSG_ERROR([Only 'iphoneos' SDKs are valid when targeting iOS device, don't know what to do with '$ios_sdk'.])
- ;;
- esac
- ;;
-*-apple-darwin*)
- ios_target_arg="-mios-simulator-version-min"
- case "$ios_sdk" in
- # Empty SDK is okay, this might be an OS X desktop build.
- ""|iphonesimulator*)
- ;;
- # Default to iphonesimulator
- yes)
- ios_sdk=iphonesimulator
- ;;
- *)
- AC_MSG_ERROR([Only 'iphonesimulator' SDKs are valid when targeting iOS simulator.])
- ;;
- esac
- ;;
-esac
-
-
-if test -n "$ios_sdk"; then
- if test -z "$_IOS_TARGET"; then
- _IOS_TARGET=$_IOS_TARGET_DEFAULT
- ios_target_arg="${ios_target_arg}=${_IOS_TARGET}"
- fi
- # Ensure that xcrun knows where this SDK is.
- ios_sdk_path=`xcrun --sdk $ios_sdk --show-sdk-path 2>/dev/null`
- _ret=$?
- if test $_ret -ne 0; then
- AC_MSG_ERROR([iOS SDK '$ios_sdk' could not be found.])
- fi
- MOZ_IOS=1
- export HOST_CC=clang
- export HOST_CXX=clang++
- # Add isysroot, arch, and ios target arguments
- case "$target_cpu" in
- arm*)
- ARGS="-arch armv7"
- ;;
- *)
- # Unfortunately simulator builds need this.
- export CROSS_COMPILE=1
- ;;
- esac
- ARGS=" $ARGS -isysroot $ios_sdk_path $ios_target_arg"
- # Now find our tools
- MOZ_IOS_PATH_PROG(CC, clang, $ARGS)
- MOZ_IOS_PATH_PROG(CXX, clang++, $ARGS)
- export CPP="$CC -E"
- export LD="$CXX"
- MOZ_IOS_PATH_PROG(AR)
- MOZ_IOS_PATH_PROG(AS, as, $ARGS)
- MOZ_IOS_PATH_PROG(OTOOL)
- MOZ_IOS_PATH_PROG(STRIP)
- export PKG_CONFIG_PATH=${ios_sdk_path}/usr/lib/pkgconfig/
-fi
-
-AC_SUBST(MOZ_IOS)
-])
diff --git a/config/rules.mk b/config/rules.mk
index 840e266ba..9730215d8 100644
--- a/config/rules.mk
+++ b/config/rules.mk
@@ -348,15 +348,11 @@ ifdef SHARED_LIBRARY
ifdef IS_COMPONENT
EXTRA_DSO_LDOPTS += -bundle
else
-ifdef MOZ_IOS
-_LOADER_PATH := @rpath
-else
_LOADER_PATH := @executable_path
endif
EXTRA_DSO_LDOPTS += -dynamiclib -install_name $(_LOADER_PATH)/$(SHARED_LIBRARY) -compatibility_version 1 -current_version 1 -single_module
endif
endif
-endif
#
# On NetBSD a.out systems, use -Bsymbolic. This fixes what would otherwise be
diff --git a/js/src/aclocal.m4 b/js/src/aclocal.m4
index 8b29b284d..22c091187 100644
--- a/js/src/aclocal.m4
+++ b/js/src/aclocal.m4
@@ -25,7 +25,6 @@ builtin(include, ../../build/autoconf/icu.m4)dnl
builtin(include, ../../build/autoconf/clang-plugin.m4)dnl
builtin(include, ../../build/autoconf/alloc.m4)dnl
builtin(include, ../../build/autoconf/sanitize.m4)dnl
-builtin(include, ../../build/autoconf/ios.m4)dnl
define([__MOZ_AC_INIT_PREPARE], defn([AC_INIT_PREPARE]))
define([AC_INIT_PREPARE],
diff --git a/js/src/old-configure.in b/js/src/old-configure.in
index 370682396..197f0428f 100644
--- a/js/src/old-configure.in
+++ b/js/src/old-configure.in
@@ -83,12 +83,6 @@ if test -n "$gonkdir" ; then
LDFLAGS="-L$gonkdir/out/target/product/$GONK_PRODUCT/obj/lib -Wl,-rpath-link=$gonkdir/out/target/product/$GONK_PRODUCT/obj/lib --sysroot=$gonkdir/out/target/product/$GONK_PRODUCT/obj/ -llog $LDFLAGS"
fi
-case "$target" in
-*-apple-darwin*)
- MOZ_IOS_SDK
- ;;
-esac
-
dnl ========================================================
dnl Checks for compilers.
dnl ========================================================
diff --git a/old-configure.in b/old-configure.in
index 18894cb28..1a7007e16 100644
--- a/old-configure.in
+++ b/old-configure.in
@@ -1879,9 +1879,6 @@ MOZ_OFFICIAL_BRANDING=
MC_OFFICIAL=
MOZ_FEEDS=1
MOZ_AUTH_EXTENSION=1
-if test "$MOZ_IOS"; then
- MOZ_AUTH_EXTENSION=
-fi
MOZ_RAW=
MOZ_AV1=
MOZ_VORBIS=