summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--build/moz-automation.mk4
-rw-r--r--system/installer/find-dupes.py (renamed from toolkit/mozapps/installer/find-dupes.py)0
-rw-r--r--system/installer/informulate.py (renamed from toolkit/mozapps/installer/informulate.py)0
-rw-r--r--system/installer/js-compare-ast.js (renamed from toolkit/mozapps/installer/js-compare-ast.js)0
-rw-r--r--system/installer/l10n-repack.py (renamed from toolkit/mozapps/installer/l10n-repack.py)0
-rw-r--r--system/installer/linux/rpm/mozilla.desktop (renamed from toolkit/mozapps/installer/linux/rpm/mozilla.desktop)0
-rw-r--r--system/installer/linux/rpm/mozilla.spec (renamed from toolkit/mozapps/installer/linux/rpm/mozilla.spec)0
-rw-r--r--system/installer/make-eme.mk (renamed from toolkit/mozapps/installer/make-eme.mk)2
-rw-r--r--system/installer/package-name.mk (renamed from toolkit/mozapps/installer/package-name.mk)0
-rw-r--r--system/installer/packager-uxp.mk (renamed from toolkit/mozapps/installer/packager-uxp.mk)2
-rw-r--r--system/installer/packager.mk (renamed from toolkit/mozapps/installer/packager.mk)14
-rw-r--r--system/installer/packager.py (renamed from toolkit/mozapps/installer/packager.py)0
-rw-r--r--system/installer/precompile_cache.js (renamed from toolkit/mozapps/installer/precompile_cache.js)0
-rw-r--r--system/installer/signing.mk (renamed from toolkit/mozapps/installer/signing.mk)0
-rw-r--r--system/installer/strip.py (renamed from toolkit/mozapps/installer/strip.py)0
-rw-r--r--system/installer/unpack.py (renamed from toolkit/mozapps/installer/unpack.py)0
-rw-r--r--system/installer/upload-files.mk (renamed from toolkit/mozapps/installer/upload-files.mk)6
-rw-r--r--[-rwxr-xr-x]system/installer/windows/nsis/common.nsh (renamed from toolkit/mozapps/installer/windows/nsis/common.nsh)0
-rw-r--r--system/installer/windows/nsis/locale-fonts.nsh (renamed from toolkit/mozapps/installer/windows/nsis/locale-fonts.nsh)0
-rw-r--r--system/installer/windows/nsis/locale-rtl.nlf (renamed from toolkit/mozapps/installer/windows/nsis/locale-rtl.nlf)0
-rw-r--r--system/installer/windows/nsis/locale.nlf (renamed from toolkit/mozapps/installer/windows/nsis/locale.nlf)0
-rw-r--r--[-rwxr-xr-x]system/installer/windows/nsis/locales.nsi (renamed from toolkit/mozapps/installer/windows/nsis/locales.nsi)0
-rw-r--r--system/installer/windows/nsis/makensis.mk (renamed from toolkit/mozapps/installer/windows/nsis/makensis.mk)6
-rw-r--r--[-rwxr-xr-x]system/installer/windows/nsis/overrides.nsh (renamed from toolkit/mozapps/installer/windows/nsis/overrides.nsh)0
-rw-r--r--system/installer/windows/nsis/preprocess-locale.py (renamed from toolkit/mozapps/installer/windows/nsis/preprocess-locale.py)2
-rw-r--r--system/installer/windows/nsis/setup.ico (renamed from toolkit/mozapps/installer/windows/nsis/setup.ico)bin25214 -> 25214 bytes
-rw-r--r--system/locales/l10n.mk6
-rw-r--r--system/updater/package/Makefile.in4
-rw-r--r--testing/testsuite-targets.mk2
-rw-r--r--toolkit/.eslintrc.js203
30 files changed, 24 insertions, 227 deletions
diff --git a/build/moz-automation.mk b/build/moz-automation.mk
index 971bdddf9..10d02ac40 100644
--- a/build/moz-automation.mk
+++ b/build/moz-automation.mk
@@ -12,8 +12,8 @@ endif
endif
ifndef JS_STANDALONE
-include $(topsrcdir)/toolkit/mozapps/installer/package-name.mk
-include $(topsrcdir)/toolkit/mozapps/installer/upload-files.mk
+include $(topsrcdir)/system/installer/package-name.mk
+include $(topsrcdir)/system/installer/upload-files.mk
# Clear out DIST_FILES if it was set
DIST_FILES =
diff --git a/toolkit/mozapps/installer/find-dupes.py b/system/installer/find-dupes.py
index 34ef675f4..34ef675f4 100644
--- a/toolkit/mozapps/installer/find-dupes.py
+++ b/system/installer/find-dupes.py
diff --git a/toolkit/mozapps/installer/informulate.py b/system/installer/informulate.py
index 6af43ac68..6af43ac68 100644
--- a/toolkit/mozapps/installer/informulate.py
+++ b/system/installer/informulate.py
diff --git a/toolkit/mozapps/installer/js-compare-ast.js b/system/installer/js-compare-ast.js
index 5b66ace37..5b66ace37 100644
--- a/toolkit/mozapps/installer/js-compare-ast.js
+++ b/system/installer/js-compare-ast.js
diff --git a/toolkit/mozapps/installer/l10n-repack.py b/system/installer/l10n-repack.py
index fcf3e773c..fcf3e773c 100644
--- a/toolkit/mozapps/installer/l10n-repack.py
+++ b/system/installer/l10n-repack.py
diff --git a/toolkit/mozapps/installer/linux/rpm/mozilla.desktop b/system/installer/linux/rpm/mozilla.desktop
index f9f3bdc34..f9f3bdc34 100644
--- a/toolkit/mozapps/installer/linux/rpm/mozilla.desktop
+++ b/system/installer/linux/rpm/mozilla.desktop
diff --git a/toolkit/mozapps/installer/linux/rpm/mozilla.spec b/system/installer/linux/rpm/mozilla.spec
index 90d132558..90d132558 100644
--- a/toolkit/mozapps/installer/linux/rpm/mozilla.spec
+++ b/system/installer/linux/rpm/mozilla.spec
diff --git a/toolkit/mozapps/installer/make-eme.mk b/system/installer/make-eme.mk
index 739703cfd..09e50a4ce 100644
--- a/toolkit/mozapps/installer/make-eme.mk
+++ b/system/installer/make-eme.mk
@@ -2,7 +2,7 @@
# License, v. 2.0. If a copy of the MPL was not distributed with this
# file, You can obtain one at http://mozilla.org/MPL/2.0/.
-include $(MOZILLA_DIR)/toolkit/mozapps/installer/signing.mk
+include $(MOZILLA_DIR)/system/installer/signing.mk
ifdef MOZ_SIGN_CMD
ifeq (,$(filter-out WINNT Darwin,$(OS_ARCH)))
diff --git a/toolkit/mozapps/installer/package-name.mk b/system/installer/package-name.mk
index 216c876e3..216c876e3 100644
--- a/toolkit/mozapps/installer/package-name.mk
+++ b/system/installer/package-name.mk
diff --git a/toolkit/mozapps/installer/packager-uxp.mk b/system/installer/packager-uxp.mk
index 8d7cb4e62..ed7ecf63d 100644
--- a/toolkit/mozapps/installer/packager-uxp.mk
+++ b/system/installer/packager-uxp.mk
@@ -4,7 +4,7 @@
# We need to include the mozilla packaging routines because we are
# very much still dependent on them
-include $(MOZILLA_DIR)/toolkit/mozapps/installer/packager.mk
+include $(MOZILLA_DIR)/system/installer/packager.mk
# This is currently only used on Windows, Linux, and Solaris
# on other platforms such as Mac will fall back to the orginal
diff --git a/toolkit/mozapps/installer/packager.mk b/system/installer/packager.mk
index 99bb0de91..b9de42315 100644
--- a/toolkit/mozapps/installer/packager.mk
+++ b/system/installer/packager.mk
@@ -2,9 +2,9 @@
# License, v. 2.0. If a copy of the MPL was not distributed with this
# file, You can obtain one at http://mozilla.org/MPL/2.0/.
-include $(MOZILLA_DIR)/toolkit/mozapps/installer/package-name.mk
-include $(MOZILLA_DIR)/toolkit/mozapps/installer/upload-files.mk
-include $(MOZILLA_DIR)/toolkit/mozapps/installer/make-eme.mk
+include $(MOZILLA_DIR)/system/installer/package-name.mk
+include $(MOZILLA_DIR)/system/installer/upload-files.mk
+include $(MOZILLA_DIR)/system/installer/make-eme.mk
# This is how we create the binary packages we release to the public.
@@ -40,7 +40,7 @@ export USE_ELF_HACK ELF_HACK_FLAGS
stage-package: $(MOZ_PKG_MANIFEST) $(MOZ_PKG_MANIFEST_DEPS)
OMNIJAR_NAME=$(OMNIJAR_NAME) \
NO_PKG_FILES="$(NO_PKG_FILES)" \
- $(PYTHON) $(MOZILLA_DIR)/toolkit/mozapps/installer/packager.py $(DEFINES) $(ACDEFINES) \
+ $(PYTHON) $(MOZILLA_DIR)/system/installer/packager.py $(DEFINES) $(ACDEFINES) \
--format $(MOZ_PACKAGER_FORMAT) \
$(addprefix --removals ,$(MOZ_PKG_REMOVALS)) \
$(if $(filter-out 0,$(MOZ_PKG_FATAL_WARNINGS)),,--ignore-errors) \
@@ -54,7 +54,7 @@ stage-package: $(MOZ_PKG_MANIFEST) $(MOZ_PKG_MANIFEST_DEPS)
$(addprefix --unify ,$(UNIFY_DIST)) \
$(MOZ_PKG_MANIFEST) '$(DIST)' '$(DIST)'/$(STAGEPATH)$(MOZ_PKG_DIR)$(if $(MOZ_PKG_MANIFEST),,$(_BINPATH)) \
$(if $(filter omni,$(MOZ_PACKAGER_FORMAT)),$(if $(NON_OMNIJAR_FILES),--non-resource $(NON_OMNIJAR_FILES)))
- $(PYTHON) $(MOZILLA_DIR)/toolkit/mozapps/installer/find-dupes.py $(DIST)/$(STAGEPATH)$(MOZ_PKG_DIR)
+ $(PYTHON) $(MOZILLA_DIR)/system/installer/find-dupes.py $(DIST)/$(STAGEPATH)$(MOZ_PKG_DIR)
@(cd $(DIST)/$(MOZ_PKG_DIR) && $(CREATE_PRECOMPLETE_CMD))
ifdef MOZ_PACKAGE_JSSHELL
# Package JavaScript Shell
@@ -90,7 +90,7 @@ endif
.PHONY: make-buildinfo-file
make-buildinfo-file:
- $(PYTHON) $(MOZILLA_DIR)/toolkit/mozapps/installer/informulate.py \
+ $(PYTHON) $(MOZILLA_DIR)/system/installer/informulate.py \
$(MOZ_BUILDINFO_FILE) \
BUILDID=$(BUILDID) \
$(addprefix MOZ_SOURCE_REPO=,MOZ_SOURCE_REPO=$(shell awk '$$2 == "MOZ_SOURCE_REPO" {print $$3}' $(DEPTH)/source-repo.h)) \
@@ -173,7 +173,7 @@ endif
(cd $(DIST)/$(MOZ_APP_NAME)-sdk/lib && tar -xf -)
$(NSINSTALL) -D $(DIST)/$(SDK_PATH)
ifndef PKG_SKIP_STRIP
- USE_ELF_HACK= $(PYTHON) $(MOZILLA_DIR)/toolkit/mozapps/installer/strip.py $(DIST)/$(MOZ_APP_NAME)-sdk
+ USE_ELF_HACK= $(PYTHON) $(MOZILLA_DIR)/system/installer/strip.py $(DIST)/$(MOZ_APP_NAME)-sdk
endif
cd $(DIST) && $(MAKE_SDK)
ifdef UNIFY_DIST
diff --git a/toolkit/mozapps/installer/packager.py b/system/installer/packager.py
index 3b90e97c2..3b90e97c2 100644
--- a/toolkit/mozapps/installer/packager.py
+++ b/system/installer/packager.py
diff --git a/toolkit/mozapps/installer/precompile_cache.js b/system/installer/precompile_cache.js
index 3eac93b65..3eac93b65 100644
--- a/toolkit/mozapps/installer/precompile_cache.js
+++ b/system/installer/precompile_cache.js
diff --git a/toolkit/mozapps/installer/signing.mk b/system/installer/signing.mk
index 0319e6983..0319e6983 100644
--- a/toolkit/mozapps/installer/signing.mk
+++ b/system/installer/signing.mk
diff --git a/toolkit/mozapps/installer/strip.py b/system/installer/strip.py
index bb83025da..bb83025da 100644
--- a/toolkit/mozapps/installer/strip.py
+++ b/system/installer/strip.py
diff --git a/toolkit/mozapps/installer/unpack.py b/system/installer/unpack.py
index 01a014422..01a014422 100644
--- a/toolkit/mozapps/installer/unpack.py
+++ b/system/installer/unpack.py
diff --git a/toolkit/mozapps/installer/upload-files.mk b/system/installer/upload-files.mk
index 3f0d1f706..4ee20d15a 100644
--- a/toolkit/mozapps/installer/upload-files.mk
+++ b/system/installer/upload-files.mk
@@ -151,11 +151,11 @@ ifeq ($(MOZ_PKG_FORMAT),RPM)
RPMBUILD_RPMDIR=$(ABS_DIST)
RPMBUILD_SRPMDIR=$(ABS_DIST)
RPMBUILD_SOURCEDIR=$(RPMBUILD_TOPDIR)/SOURCES
- RPMBUILD_SPECDIR=$(topsrcdir)/toolkit/mozapps/installer/linux/rpm
+ RPMBUILD_SPECDIR=$(topsrcdir)/system/installer/linux/rpm
RPMBUILD_BUILDDIR=$(ABS_DIST)/..
SPEC_FILE = $(RPMBUILD_SPECDIR)/mozilla.spec
- RPM_INCIDENTALS=$(topsrcdir)/toolkit/mozapps/installer/linux/rpm
+ RPM_INCIDENTALS=$(topsrcdir)/system/installer/linux/rpm
RPM_CMD = \
echo Creating RPM && \
@@ -231,7 +231,7 @@ endif #Create an RPM file
ifeq ($(MOZ_PKG_FORMAT),APK)
-include $(MOZILLA_DIR)/toolkit/mozapps/installer/upload-files-$(MOZ_PKG_FORMAT).mk
+include $(MOZILLA_DIR)/system/installer/upload-files-$(MOZ_PKG_FORMAT).mk
endif
ifeq ($(MOZ_PKG_FORMAT),DMG)
diff --git a/toolkit/mozapps/installer/windows/nsis/common.nsh b/system/installer/windows/nsis/common.nsh
index ed15a09f5..ed15a09f5 100755..100644
--- a/toolkit/mozapps/installer/windows/nsis/common.nsh
+++ b/system/installer/windows/nsis/common.nsh
diff --git a/toolkit/mozapps/installer/windows/nsis/locale-fonts.nsh b/system/installer/windows/nsis/locale-fonts.nsh
index 4149deadb..4149deadb 100644
--- a/toolkit/mozapps/installer/windows/nsis/locale-fonts.nsh
+++ b/system/installer/windows/nsis/locale-fonts.nsh
diff --git a/toolkit/mozapps/installer/windows/nsis/locale-rtl.nlf b/system/installer/windows/nsis/locale-rtl.nlf
index a4ea9ae6e..a4ea9ae6e 100644
--- a/toolkit/mozapps/installer/windows/nsis/locale-rtl.nlf
+++ b/system/installer/windows/nsis/locale-rtl.nlf
diff --git a/toolkit/mozapps/installer/windows/nsis/locale.nlf b/system/installer/windows/nsis/locale.nlf
index 0995026a0..0995026a0 100644
--- a/toolkit/mozapps/installer/windows/nsis/locale.nlf
+++ b/system/installer/windows/nsis/locale.nlf
diff --git a/toolkit/mozapps/installer/windows/nsis/locales.nsi b/system/installer/windows/nsis/locales.nsi
index 938aef47f..938aef47f 100755..100644
--- a/toolkit/mozapps/installer/windows/nsis/locales.nsi
+++ b/system/installer/windows/nsis/locales.nsi
diff --git a/toolkit/mozapps/installer/windows/nsis/makensis.mk b/system/installer/windows/nsis/makensis.mk
index 121819f6a..d49d50bd9 100644
--- a/toolkit/mozapps/installer/windows/nsis/makensis.mk
+++ b/system/installer/windows/nsis/makensis.mk
@@ -6,7 +6,7 @@ ifndef CONFIG_DIR
$(error CONFIG_DIR must be set before including makensis.mk)
endif
-include $(MOZILLA_DIR)/toolkit/mozapps/installer/signing.mk
+include $(MOZILLA_DIR)/system/installer/signing.mk
ABS_CONFIG_DIR := $(abspath $(CONFIG_DIR))
@@ -41,7 +41,7 @@ CUSTOM_UI = \
$(NULL)
$(CONFIG_DIR)/setup.exe::
- $(INSTALL) $(addprefix $(MOZILLA_DIR)/toolkit/mozapps/installer/windows/nsis/,$(TOOLKIT_NSIS_FILES)) $(CONFIG_DIR)
+ $(INSTALL) $(addprefix $(MOZILLA_DIR)/system/installer/windows/nsis/,$(TOOLKIT_NSIS_FILES)) $(CONFIG_DIR)
$(INSTALL) $(addprefix $(MOZILLA_DIR)/other-licenses/nsis/Plugins/,$(CUSTOM_NSIS_PLUGINS)) $(CONFIG_DIR)
$(INSTALL) $(addprefix $(MOZILLA_DIR)/other-licenses/nsis/,$(CUSTOM_UI)) $(CONFIG_DIR)
cd $(CONFIG_DIR) && $(MAKENSISU) installer.nsi
@@ -70,7 +70,7 @@ endif
# For building the uninstaller during the application build so it can be
# included for mar file generation.
uninstaller::
- $(INSTALL) $(addprefix $(MOZILLA_DIR)/toolkit/mozapps/installer/windows/nsis/,$(TOOLKIT_NSIS_FILES)) $(CONFIG_DIR)
+ $(INSTALL) $(addprefix $(MOZILLA_DIR)/system/installer/windows/nsis/,$(TOOLKIT_NSIS_FILES)) $(CONFIG_DIR)
$(INSTALL) $(addprefix $(MOZILLA_DIR)/other-licenses/nsis/Plugins/,$(CUSTOM_NSIS_PLUGINS)) $(CONFIG_DIR)
cd $(CONFIG_DIR) && $(MAKENSISU) uninstaller.nsi
$(NSINSTALL) -D $(DIST)/bin/uninstall
diff --git a/toolkit/mozapps/installer/windows/nsis/overrides.nsh b/system/installer/windows/nsis/overrides.nsh
index 5d1f26965..5d1f26965 100755..100644
--- a/toolkit/mozapps/installer/windows/nsis/overrides.nsh
+++ b/system/installer/windows/nsis/overrides.nsh
diff --git a/toolkit/mozapps/installer/windows/nsis/preprocess-locale.py b/system/installer/windows/nsis/preprocess-locale.py
index cb7303a12..729ddbf64 100644
--- a/toolkit/mozapps/installer/windows/nsis/preprocess-locale.py
+++ b/system/installer/windows/nsis/preprocess-locale.py
@@ -124,7 +124,7 @@ def create_nlf_file(moz_dir, ab_cd, config_dir):
# Check whether the locale is right to left from locales.nsi.
fp = open(join(moz_dir,
- "toolkit/mozapps/installer/windows/nsis/locales.nsi"),
+ "system/installer/windows/nsis/locales.nsi"),
"r")
for line in fp:
line = line.strip()
diff --git a/toolkit/mozapps/installer/windows/nsis/setup.ico b/system/installer/windows/nsis/setup.ico
index 9801fed54..9801fed54 100644
--- a/toolkit/mozapps/installer/windows/nsis/setup.ico
+++ b/system/installer/windows/nsis/setup.ico
Binary files differ
diff --git a/system/locales/l10n.mk b/system/locales/l10n.mk
index b7668645b..ad8da1782 100644
--- a/system/locales/l10n.mk
+++ b/system/locales/l10n.mk
@@ -73,8 +73,8 @@ else
STAGEDIST = $(ABS_DIST)/l10n-stage/$(MOZ_PKG_DIR)
endif
-include $(MOZILLA_DIR)/toolkit/mozapps/installer/signing.mk
-include $(MOZILLA_DIR)/toolkit/mozapps/installer/packager.mk
+include $(MOZILLA_DIR)/system/installer/signing.mk
+include $(MOZILLA_DIR)/system/installer/packager.mk
PACKAGE_BASE_DIR = $(ABS_DIST)/l10n-stage
@@ -112,7 +112,7 @@ repackage-zip: UNPACKAGE='$(ZIP_IN)'
repackage-zip: libs-$(AB_CD)
# call a hook for apps to put their uninstall helper.exe into the package
$(UNINSTALLER_PACKAGE_HOOK)
- $(PYTHON) $(MOZILLA_DIR)/toolkit/mozapps/installer/l10n-repack.py '$(STAGEDIST)' $(DIST)/xpi-stage/locale-$(AB_CD) \
+ $(PYTHON) $(MOZILLA_DIR)/system/installer/l10n-repack.py '$(STAGEDIST)' $(DIST)/xpi-stage/locale-$(AB_CD) \
$(MOZ_PKG_EXTRAL10N) \
$(if $(filter omni,$(MOZ_PACKAGER_FORMAT)),$(if $(NON_OMNIJAR_FILES),--non-resource $(NON_OMNIJAR_FILES)))
diff --git a/system/updater/package/Makefile.in b/system/updater/package/Makefile.in
index 4788a5575..eab4c7123 100644
--- a/system/updater/package/Makefile.in
+++ b/system/updater/package/Makefile.in
@@ -40,8 +40,8 @@ endif
endif
include $(topsrcdir)/config/rules.mk
-include $(topsrcdir)/toolkit/mozapps/installer/signing.mk
-include $(topsrcdir)/toolkit/mozapps/installer/packager.mk
+include $(topsrcdir)/system/installer/signing.mk
+include $(topsrcdir)/system/installer/packager.mk
ifdef MOZ_EXTERNAL_SIGNING_FORMAT
# We can't use sha2signcode on mar files
diff --git a/testing/testsuite-targets.mk b/testing/testsuite-targets.mk
index cd4017c8d..8a3a46251 100644
--- a/testing/testsuite-targets.mk
+++ b/testing/testsuite-targets.mk
@@ -146,7 +146,7 @@ pgo-profile-run:
$(PYTHON) $(topsrcdir)/build/pgo/profileserver.py $(EXTRA_TEST_ARGS)
# Package up the tests and test harnesses
-include $(topsrcdir)/toolkit/mozapps/installer/package-name.mk
+include $(topsrcdir)/system/installer/package-name.mk
PKG_STAGE = $(DIST)/test-stage
diff --git a/toolkit/.eslintrc.js b/toolkit/.eslintrc.js
deleted file mode 100644
index 891a114b3..000000000
--- a/toolkit/.eslintrc.js
+++ /dev/null
@@ -1,203 +0,0 @@
-"use strict";
-
-module.exports = {
- // When adding items to this file please check for effects on all of toolkit
- // and browser
- "rules": {
- // Braces only needed for multi-line arrow function blocks
- // "arrow-body-style": ["error", "as-needed"],
-
- // Require spacing around =>
- "arrow-spacing": "error",
-
- // Always require spacing around a single line block
- "block-spacing": "error",
-
- // No newline before open brace for a block
- // "brace-style": "error",
-
- // No space before always a space after a comma
- "comma-spacing": ["error", {"before": false, "after": true}],
-
- // Commas at the end of the line not the start
- // "comma-style": "error",
-
- // Don't require spaces around computed properties
- "computed-property-spacing": ["error", "never"],
-
- // Functions must always return something or nothing
- "consistent-return": "error",
-
- // Require braces around blocks that start a new line
- // Note that this rule is likely to be overridden on a per-directory basis
- // very frequently.
- // "curly": ["error", "multi-line"],
-
- // Always require a trailing EOL
- "eol-last": "error",
-
- // Require function* name()
- // "generator-star-spacing": ["error", {"before": false, "after": true}],
-
- // Two space indent
- // "indent": ["error", 2, { "SwitchCase": 1 }],
-
- // Space after colon not before in property declarations
- // "key-spacing": ["error", { "beforeColon": false, "afterColon": true, "mode": "minimum" }],
-
- // Require spaces before and after keywords
- "keyword-spacing": "error",
-
- // Unix linebreaks
- "linebreak-style": ["error", "unix"],
-
- // Always require parenthesis for new calls
- // "new-parens": "error",
-
- // Use [] instead of Array()
- // "no-array-constructor": "error",
-
- // No duplicate arguments in function declarations
- "no-dupe-args": "error",
-
- // No duplicate keys in object declarations
- "no-dupe-keys": "error",
-
- // No duplicate cases in switch statements
- "no-duplicate-case": "error",
-
- // No labels
- "no-labels": "error",
-
- // If an if block ends with a return no need for an else block
- "no-else-return": "error",
-
- // No empty statements
- "no-empty": ["error", {"allowEmptyCatch": true}],
-
- // No empty character classes in regex
- "no-empty-character-class": "error",
-
- // Disallow empty destructuring
- "no-empty-pattern": "error",
-
- // No assiging to exception variable
- "no-ex-assign": "error",
-
- // No using !! where casting to boolean is already happening
- "no-extra-boolean-cast": "error",
-
- // No double semicolon
- "no-extra-semi": "error",
-
- // No overwriting defined functions
- "no-func-assign": "error",
-
- // No invalid regular expresions
- "no-invalid-regexp": "error",
-
- // No odd whitespace characters
- "no-irregular-whitespace": "error",
-
- // No single if block inside an else block
- "no-lonely-if": "error",
-
- // No mixing spaces and tabs in indent
- "no-mixed-spaces-and-tabs": ["error", "smart-tabs"],
-
- // No unnecessary spacing
- // "no-multi-spaces": ["error", { exceptions: { "AssignmentExpression": true, "VariableDeclarator": true, "ArrayExpression": true, "ObjectExpression": true } }],
-
- // No reassigning native JS objects
- "no-native-reassign": "error",
-
- // Nested ternary statements are confusing
- "no-nested-ternary": "error",
-
- // Use {} instead of new Object()
- "no-new-object": "error",
-
- // No Math() or JSON()
- "no-obj-calls": "error",
-
- // No octal literals
- "no-octal": "error",
-
- // No redeclaring variables
- "no-redeclare": "error",
-
- // No unnecessary comparisons
- "no-self-compare": "error",
-
- // No declaring variables from an outer scope
- // "no-shadow": "error",
-
- // No declaring variables that hide things like arguments
- "no-shadow-restricted-names": "error",
-
- // No spaces between function name and parentheses
- // "no-spaced-func": "error",
-
- // No trailing whitespace
- "no-trailing-spaces": "error",
-
- // No using undeclared variables
- // "no-undef": "error",
-
- // Error on newline where a semicolon is needed
- "no-unexpected-multiline": "error",
-
- // No unreachable statements
- "no-unreachable": "error",
-
- // No declaring variables that are never used
- // "no-unused-vars": ["error", {
- // "vars": "local",
- // "varsIgnorePattern": "^Cc|Ci|Cu|Cr|EXPORTED_SYMBOLS",
- // "args": "none",
- // }],
-
- // No using variables before defined
- // "no-use-before-define": ["error", "nofunc"],
-
- // No using with
- "no-with": "error",
-
- // Always require semicolon at end of statement
- // "semi": ["error", "always"],
-
- // Require space before blocks
- "space-before-blocks": "error",
-
- // Never use spaces before function parentheses
- // "space-before-function-paren": ["error", { "anonymous": "always", "named": "never" }],
-
- // No space padding in parentheses
- // "space-in-parens": ["error", "never"],
-
- // Require spaces around operators
- // "space-infix-ops": "error",
-
- // ++ and -- should not need spacing
- // "space-unary-ops": ["error", { "words": true, "nonwords": false }],
-
- // Requires or disallows a whitespace (space or tab) beginning a comment
- "spaced-comment": "error",
-
- // No comparisons to NaN
- "use-isnan": "error",
-
- // Only check typeof against valid results
- "valid-typeof": "error",
- },
- "env": {
- "es6": true,
- "browser": true,
- },
- "globals": {
- "Components": false,
- "dump": true,
- "openDialog": false,
- "sizeToContent": false,
- }
-};