summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorMatt A. Tobin <email@mattatobin.com>2022-03-25 00:22:35 -0500
committerMatt A. Tobin <email@mattatobin.com>2022-03-25 00:22:35 -0500
commitf8e97b57f995d1763d8bd53c2b636ee67a826bb7 (patch)
tree9fd915746b9dd45638de83d6d27571fe730d1a0d /system
parentb7e4e4717cb95a05e9b47e663e49621cceacd6ad (diff)
downloadaura-central-f8e97b57f995d1763d8bd53c2b636ee67a826bb7.tar.gz
Remove mozinstaller
Diffstat (limited to 'system')
-rw-r--r--system/packager/base.mk2
-rw-r--r--system/packager/find-dupes.py (renamed from system/installer/find-dupes.py)0
-rw-r--r--system/packager/informulate.py (renamed from system/installer/informulate.py)0
-rw-r--r--system/packager/installer.mk6
-rw-r--r--system/packager/js-compare-ast.js (renamed from system/installer/js-compare-ast.js)0
-rw-r--r--system/packager/l10n-repack.py (renamed from system/installer/l10n-repack.py)0
-rw-r--r--system/packager/nsis/common.nsh (renamed from system/installer/windows/nsis/common.nsh)0
-rw-r--r--system/packager/nsis/locale-fonts.nsh (renamed from system/installer/windows/nsis/locale-fonts.nsh)0
-rw-r--r--system/packager/nsis/locale-rtl.nlf (renamed from system/installer/windows/nsis/locale-rtl.nlf)0
-rw-r--r--system/packager/nsis/locale.nlf (renamed from system/installer/windows/nsis/locale.nlf)0
-rw-r--r--system/packager/nsis/locales.nsi (renamed from system/installer/windows/nsis/locales.nsi)0
-rw-r--r--system/packager/nsis/makensis.mk (renamed from system/installer/windows/nsis/makensis.mk)16
-rw-r--r--system/packager/nsis/overrides.nsh (renamed from system/installer/windows/nsis/overrides.nsh)0
-rw-r--r--system/packager/nsis/preprocess-locale.py (renamed from system/installer/windows/nsis/preprocess-locale.py)0
-rw-r--r--system/packager/nsis/setup.ico (renamed from system/installer/windows/nsis/setup.ico)bin25214 -> 25214 bytes
-rw-r--r--system/packager/packager.py (renamed from system/installer/packager.py)0
-rw-r--r--system/packager/precompile_cache.js (renamed from system/installer/precompile_cache.js)0
-rw-r--r--system/packager/strip.py (renamed from system/installer/strip.py)0
-rw-r--r--system/packager/unpack.py (renamed from system/installer/unpack.py)0
19 files changed, 6 insertions, 18 deletions
diff --git a/system/packager/base.mk b/system/packager/base.mk
index b475f6ed1..3a3f8d76a 100644
--- a/system/packager/base.mk
+++ b/system/packager/base.mk
@@ -13,7 +13,7 @@ endif # GREPKGR_BASE_MK_INCLUDED
# ---------------------------------------------------------------------------------------------------------------------
# These vars are here so that if paths change the number of places that need to be changed is minimal.
-MOZINST_PATH := $(MOZILLA_DIR)/system/installer
+MOZINST_PATH := $(MOZILLA_DIR)/system/packager
GREPKGR_PATH := $(MOZILLA_DIR)/system/packager
# ---------------------------------------------------------------------------------------------------------------------
diff --git a/system/installer/find-dupes.py b/system/packager/find-dupes.py
index 34ef675f4..34ef675f4 100644
--- a/system/installer/find-dupes.py
+++ b/system/packager/find-dupes.py
diff --git a/system/installer/informulate.py b/system/packager/informulate.py
index 6af43ac68..6af43ac68 100644
--- a/system/installer/informulate.py
+++ b/system/packager/informulate.py
diff --git a/system/packager/installer.mk b/system/packager/installer.mk
index a9c0447ec..1751432c4 100644
--- a/system/packager/installer.mk
+++ b/system/packager/installer.mk
@@ -42,7 +42,7 @@ $(CONFIG_DIR)/7zSD.sfx:
$(CONFIG_DIR)/setup.exe::
$(INSTALL) $(addprefix $(srcdir)/,$(INSTALLER_FILES)) $(CONFIG_DIR)
$(INSTALL) $(addprefix $(DIST)/branding/,$(BRANDING_FILES)) $(CONFIG_DIR)
- $(INSTALL) $(addprefix $(MOZINST_PATH)/windows/nsis/,$(TOOLKIT_NSIS_FILES)) $(CONFIG_DIR)
+ $(INSTALL) $(addprefix $(MOZINST_PATH)/nsis/,$(TOOLKIT_NSIS_FILES)) $(CONFIG_DIR)
$(INSTALL) $(addprefix $(MOZILLA_DIR)/other-licenses/nsis/Plugins/,$(CUSTOM_NSIS_PLUGINS)) $(CONFIG_DIR)
$(INSTALL) $(addprefix $(MOZILLA_DIR)/other-licenses/nsis/,$(CUSTOM_UI)) $(CONFIG_DIR)
$(call py_action,preprocessor,-Fsubstitution $(DEFINES) $(ACDEFINES) \
@@ -70,11 +70,11 @@ uninstaller::
$(RM) -r $(CONFIG_DIR) && mkdir $(CONFIG_DIR)
$(INSTALL) $(addprefix $(srcdir)/,$(INSTALLER_FILES)) $(CONFIG_DIR)
$(INSTALL) $(addprefix $(DIST)/branding/,$(BRANDING_FILES)) $(CONFIG_DIR)
- $(INSTALL) $(addprefix $(MOZINST_PATH)/windows/nsis/,$(TOOLKIT_NSIS_FILES)) $(CONFIG_DIR)
+ $(INSTALL) $(addprefix $(MOZINST_PATH)/nsis/,$(TOOLKIT_NSIS_FILES)) $(CONFIG_DIR)
$(INSTALL) $(addprefix $(MOZILLA_DIR)/other-licenses/nsis/Plugins/,$(CUSTOM_NSIS_PLUGINS)) $(CONFIG_DIR)
$(call py_action,preprocessor,-Fsubstitution $(DEFINES) $(ACDEFINES) \
$(srcdir)/src/defines.nsi.in -o $(CONFIG_DIR)/defines.nsi)
- $(PYTHON) $(MOZINST_PATH)/windows/nsis/preprocess-locale.py --preprocess-locale \
+ $(PYTHON) $(MOZINST_PATH)/nsis/preprocess-locale.py --preprocess-locale \
$(MOZILLA_SRCDIR) $(abspath $(srcdir))/locale $(AB_CD) $(CONFIG_DIR)
$(NSINSTALL) -D $(DIST)/bin/uninstall
cd $(CONFIG_DIR) && $(MAKENSISU) uninstaller.nsi
diff --git a/system/installer/js-compare-ast.js b/system/packager/js-compare-ast.js
index 5b66ace37..5b66ace37 100644
--- a/system/installer/js-compare-ast.js
+++ b/system/packager/js-compare-ast.js
diff --git a/system/installer/l10n-repack.py b/system/packager/l10n-repack.py
index fcf3e773c..fcf3e773c 100644
--- a/system/installer/l10n-repack.py
+++ b/system/packager/l10n-repack.py
diff --git a/system/installer/windows/nsis/common.nsh b/system/packager/nsis/common.nsh
index ed15a09f5..ed15a09f5 100644
--- a/system/installer/windows/nsis/common.nsh
+++ b/system/packager/nsis/common.nsh
diff --git a/system/installer/windows/nsis/locale-fonts.nsh b/system/packager/nsis/locale-fonts.nsh
index 4149deadb..4149deadb 100644
--- a/system/installer/windows/nsis/locale-fonts.nsh
+++ b/system/packager/nsis/locale-fonts.nsh
diff --git a/system/installer/windows/nsis/locale-rtl.nlf b/system/packager/nsis/locale-rtl.nlf
index a4ea9ae6e..a4ea9ae6e 100644
--- a/system/installer/windows/nsis/locale-rtl.nlf
+++ b/system/packager/nsis/locale-rtl.nlf
diff --git a/system/installer/windows/nsis/locale.nlf b/system/packager/nsis/locale.nlf
index 0995026a0..0995026a0 100644
--- a/system/installer/windows/nsis/locale.nlf
+++ b/system/packager/nsis/locale.nlf
diff --git a/system/installer/windows/nsis/locales.nsi b/system/packager/nsis/locales.nsi
index 938aef47f..938aef47f 100644
--- a/system/installer/windows/nsis/locales.nsi
+++ b/system/packager/nsis/locales.nsi
diff --git a/system/installer/windows/nsis/makensis.mk b/system/packager/nsis/makensis.mk
index d49d50bd9..eecfc322b 100644
--- a/system/installer/windows/nsis/makensis.mk
+++ b/system/packager/nsis/makensis.mk
@@ -6,8 +6,6 @@ ifndef CONFIG_DIR
$(error CONFIG_DIR must be set before including makensis.mk)
endif
-include $(MOZILLA_DIR)/system/installer/signing.mk
-
ABS_CONFIG_DIR := $(abspath $(CONFIG_DIR))
SFX_MODULE ?= $(error SFX_MODULE is not defined)
@@ -41,17 +39,10 @@ CUSTOM_UI = \
$(NULL)
$(CONFIG_DIR)/setup.exe::
- $(INSTALL) $(addprefix $(MOZILLA_DIR)/system/installer/windows/nsis/,$(TOOLKIT_NSIS_FILES)) $(CONFIG_DIR)
+ $(INSTALL) $(addprefix $(MOZILLA_DIR)/system/packager/nsis/,$(TOOLKIT_NSIS_FILES)) $(CONFIG_DIR)
$(INSTALL) $(addprefix $(MOZILLA_DIR)/other-licenses/nsis/Plugins/,$(CUSTOM_NSIS_PLUGINS)) $(CONFIG_DIR)
$(INSTALL) $(addprefix $(MOZILLA_DIR)/other-licenses/nsis/,$(CUSTOM_UI)) $(CONFIG_DIR)
cd $(CONFIG_DIR) && $(MAKENSISU) installer.nsi
-# Support for building the uninstaller when repackaging locales
-ifeq ($(CONFIG_DIR),l10ngen)
- cd $(CONFIG_DIR) && $(MAKENSISU) uninstaller.nsi
-endif
-ifdef MOZ_EXTERNAL_SIGNING_FORMAT
- $(MOZ_SIGN_CMD) $(foreach f,$(MOZ_EXTERNAL_SIGNING_FORMAT),-f $(f)) "$@"
-endif
$(CONFIG_DIR)/7zSD.sfx:
$(CYGWIN_WRAPPER) upx --best -o $(CONFIG_DIR)/7zSD.sfx $(SFX_MODULE)
@@ -63,14 +54,11 @@ installer::
$(NSINSTALL) -D $(DIST)/$(PKG_INST_PATH)
cat $(CONFIG_DIR)/7zSD.sfx $(CONFIG_DIR)/app.tag $(CONFIG_DIR)/app.7z > "$(DIST)/$(PKG_INST_PATH)$(PKG_INST_BASENAME).exe"
chmod 0755 "$(DIST)/$(PKG_INST_PATH)$(PKG_INST_BASENAME).exe"
-ifdef MOZ_EXTERNAL_SIGNING_FORMAT
- $(MOZ_SIGN_CMD) $(foreach f,$(MOZ_EXTERNAL_SIGNING_FORMAT),-f $(f)) "$(DIST)/$(PKG_INST_PATH)$(PKG_INST_BASENAME).exe"
-endif
# For building the uninstaller during the application build so it can be
# included for mar file generation.
uninstaller::
- $(INSTALL) $(addprefix $(MOZILLA_DIR)/system/installer/windows/nsis/,$(TOOLKIT_NSIS_FILES)) $(CONFIG_DIR)
+ $(INSTALL) $(addprefix $(MOZILLA_DIR)/system/packager/nsis/,$(TOOLKIT_NSIS_FILES)) $(CONFIG_DIR)
$(INSTALL) $(addprefix $(MOZILLA_DIR)/other-licenses/nsis/Plugins/,$(CUSTOM_NSIS_PLUGINS)) $(CONFIG_DIR)
cd $(CONFIG_DIR) && $(MAKENSISU) uninstaller.nsi
$(NSINSTALL) -D $(DIST)/bin/uninstall
diff --git a/system/installer/windows/nsis/overrides.nsh b/system/packager/nsis/overrides.nsh
index 5d1f26965..5d1f26965 100644
--- a/system/installer/windows/nsis/overrides.nsh
+++ b/system/packager/nsis/overrides.nsh
diff --git a/system/installer/windows/nsis/preprocess-locale.py b/system/packager/nsis/preprocess-locale.py
index 729ddbf64..729ddbf64 100644
--- a/system/installer/windows/nsis/preprocess-locale.py
+++ b/system/packager/nsis/preprocess-locale.py
diff --git a/system/installer/windows/nsis/setup.ico b/system/packager/nsis/setup.ico
index 9801fed54..9801fed54 100644
--- a/system/installer/windows/nsis/setup.ico
+++ b/system/packager/nsis/setup.ico
Binary files differ
diff --git a/system/installer/packager.py b/system/packager/packager.py
index 3b90e97c2..3b90e97c2 100644
--- a/system/installer/packager.py
+++ b/system/packager/packager.py
diff --git a/system/installer/precompile_cache.js b/system/packager/precompile_cache.js
index 3eac93b65..3eac93b65 100644
--- a/system/installer/precompile_cache.js
+++ b/system/packager/precompile_cache.js
diff --git a/system/installer/strip.py b/system/packager/strip.py
index bb83025da..bb83025da 100644
--- a/system/installer/strip.py
+++ b/system/packager/strip.py
diff --git a/system/installer/unpack.py b/system/packager/unpack.py
index 01a014422..01a014422 100644
--- a/system/installer/unpack.py
+++ b/system/packager/unpack.py