summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorMoonchild <moonchild@palemoon.org>2022-02-20 22:00:59 +0000
committerMoonchild <moonchild@palemoon.org>2022-03-21 13:23:02 +0000
commite0d9f5cda41908bd0cf9ab8f356206c2f5ac7e6c (patch)
tree424a06997bce76c83effe2790aebde7ee93176aa /system
parent7bfd6315deae1d579a62122d8f913baaf2afafba (diff)
downloadaura-central-e0d9f5cda41908bd0cf9ab8f356206c2f5ac7e6c.tar.gz
No issue - Research and resolve NIGHTLY_BUILD conditionals
Diffstat (limited to 'system')
-rw-r--r--system/framework/WeakPtr.h2
-rw-r--r--system/goanna.js55
-rw-r--r--system/graphics/src/DriverCrashGuard.cpp8
-rw-r--r--system/graphics/thebes/gfxEnv.h1
-rw-r--r--system/packager/base.mk4
5 files changed, 6 insertions, 64 deletions
diff --git a/system/framework/WeakPtr.h b/system/framework/WeakPtr.h
index 477c56bbf..a3164c3f8 100644
--- a/system/framework/WeakPtr.h
+++ b/system/framework/WeakPtr.h
@@ -99,7 +99,7 @@
// b. switch to POSIX-based threading in MinGW with pthread emulation
// c. refactor it to not use std::thread
-#if !defined(__MINGW32__) && (defined(DEBUG) || (defined(NIGHTLY_BUILD) && !defined(MOZ_PROFILING)))
+#if !defined(__MINGW32__) && defined(DEBUG)
#include <thread>
#define MOZ_WEAKPTR_DECLARE_THREAD_SAFETY_CHECK \
diff --git a/system/goanna.js b/system/goanna.js
index d9369d82c..8d4d6b98d 100644
--- a/system/goanna.js
+++ b/system/goanna.js
@@ -152,11 +152,7 @@ pref("dom.manifest.onappinstalled", false);
pref("dom.select_events.enabled", true);
// Whether or not selection events on text controls are enabled
-#ifdef NIGHTLY_BUILD
pref("dom.select_events.textcontrols.enabled", true);
-#else
-pref("dom.select_events.textcontrols.enabled", false);
-#endif
// Whether or not the document visbility API is enabled
pref("dom.visibilityAPI.enabled", true);
@@ -204,11 +200,7 @@ pref("dom.permissions.revoke.enable", false);
pref("dom.performance.time_to_non_blank_paint.enabled", false);
// Enable Performance Observer API
-#ifdef NIGHTLY_BUILD
pref("dom.enable_performance_observer", true);
-#else
-pref("dom.enable_performance_observer", false);
-#endif
// Enable requestIdleCallback API
pref("dom.requestIdleCallback.enabled", true);
@@ -348,12 +340,8 @@ pref("mathml.disabled", false);
// Enable scale transform for stretchy MathML operators. See bug 414277.
pref("mathml.scale_stretchy_operators.enabled", true);
-// Enabled on nightly only until we fix mochitest failures.
-#ifdef NIGHTLY_BUILD
-pref("media.dormant-on-pause-timeout-ms", 5000);
-#else
-pref("media.dormant-on-pause-timeout-ms", -1);
-#endif
+// Set media to be dormant if paused for more than 15 seconds to reduce resources.
+pref("media.dormant-on-pause-timeout-ms", 15000);
// Audio backend override
pref("media.cubeb.backend", "");
@@ -393,11 +381,7 @@ pref("media.wmf.enabled", true);
pref("media.wmf.decoder.thread-count", -1);
pref("media.wmf.low-latency.enabled", false);
pref("media.wmf.skip-blacklist", false);
-#ifdef NIGHTLY_BUILD
pref("media.wmf.vp9.enabled", true);
-#else
-pref("media.wmf.vp9.enabled", false);
-#endif
pref("media.windows-media-foundation.allow-d3d11-dxva", true);
pref("media.wmf.disable-d3d11-for-dlls", "igd11dxva64.dll: 20.19.15.4463, 20.19.15.4454, 20.19.15.4444, 20.19.15.4416, 20.19.15.4404, 20.19.15.4390, 20.19.15.4380, 20.19.15.4377, 20.19.15.4364, 20.19.15.4360, 20.19.15.4352, 20.19.15.4331, 20.19.15.4326, 20.19.15.4300; igd10iumd32.dll: 20.19.15.4444, 20.19.15.4424, 20.19.15.4409, 20.19.15.4390, 20.19.15.4380, 20.19.15.4360, 10.18.10.4358, 20.19.15.4331, 20.19.15.4312, 20.19.15.4300, 10.18.15.4281, 10.18.15.4279, 10.18.10.4276, 10.18.15.4268, 10.18.15.4256, 10.18.10.4252, 10.18.15.4248, 10.18.14.4112, 10.18.10.3958, 10.18.10.3496, 10.18.10.3431, 10.18.10.3412, 10.18.10.3355, 9.18.10.3234, 9.18.10.3071, 9.18.10.3055, 9.18.10.3006; igd10umd32.dll: 9.17.10.4229, 9.17.10.3040, 9.17.10.2857, 8.15.10.2274, 8.15.10.2272, 8.15.10.2246, 8.15.10.1840, 8.15.10.1808; igd10umd64.dll: 9.17.10.4229, 9.17.10.2857, 10.18.10.3496; isonyvideoprocessor.dll: 4.1.2247.8090, 4.1.2153.6200; tosqep.dll: 1.2.15.526, 1.1.12.201, 1.0.11.318, 1.0.11.215, 1.0.10.1224; tosqep64.dll: 1.1.12.201, 1.0.11.215; nvwgf2um.dll: 22.21.13.8253, 22.21.13.8233, 22.21.13.8205, 22.21.13.8189, 22.21.13.8178, 22.21.13.8165, 21.21.13.7892, 21.21.13.7878, 21.21.13.7866, 21.21.13.7849, 21.21.13.7654, 21.21.13.7653, 21.21.13.7633, 21.21.13.7619, 21.21.13.7563, 21.21.13.7306, 21.21.13.7290, 21.21.13.7270, 21.21.13.7254, 21.21.13.6939, 21.21.13.6926, 21.21.13.6909, 21.21.13.4201, 21.21.13.4200, 10.18.13.6881, 10.18.13.6839, 10.18.13.6510, 10.18.13.6472, 10.18.13.6143, 10.18.13.5946, 10.18.13.5923, 10.18.13.5921, 10.18.13.5891, 10.18.13.5887, 10.18.13.5582, 10.18.13.5445, 10.18.13.5382, 10.18.13.5362, 9.18.13.4788, 9.18.13.4752, 9.18.13.4725, 9.18.13.4709, 9.18.13.4195, 9.18.13.4192, 9.18.13.4144, 9.18.13.4052, 9.18.13.3788, 9.18.13.3523, 9.18.13.3235, 9.18.13.3165, 9.18.13.2723, 9.18.13.2702, 9.18.13.1422, 9.18.13.1407, 9.18.13.1106, 9.18.13.546; atidxx32.dll: 21.19.151.3, 21.19.142.257, 21.19.137.514, 21.19.137.1, 21.19.134.1, 21.19.128.7, 21.19.128.4, 20.19.0.32837, 20.19.0.32832, 8.17.10.682, 8.17.10.671, 8.17.10.661, 8.17.10.648, 8.17.10.644, 8.17.10.625, 8.17.10.605, 8.17.10.581, 8.17.10.569, 8.17.10.560, 8.17.10.545, 8.17.10.539, 8.17.10.531, 8.17.10.525, 8.17.10.520, 8.17.10.519, 8.17.10.514, 8.17.10.511, 8.17.10.494, 8.17.10.489, 8.17.10.483, 8.17.10.453, 8.17.10.451, 8.17.10.441, 8.17.10.436, 8.17.10.432, 8.17.10.425, 8.17.10.418, 8.17.10.414, 8.17.10.401, 8.17.10.395, 8.17.10.385, 8.17.10.378, 8.17.10.362, 8.17.10.355, 8.17.10.342, 8.17.10.331, 8.17.10.318, 8.17.10.310, 8.17.10.286, 8.17.10.269, 8.17.10.261, 8.17.10.247, 8.17.10.240, 8.15.10.212; atidxx64.dll: 21.19.151.3, 21.19.142.257, 21.19.137.514, 21.19.137.1, 21.19.134.1, 21.19.128.7, 21.19.128.4, 20.19.0.32832, 8.17.10.682, 8.17.10.661, 8.17.10.644, 8.17.10.625; nvumdshim.dll: 10.18.13.6822");
pref("media.wmf.disable-d3d9-for-dlls", "igdumd64.dll: 8.15.10.2189, 8.15.10.2119, 8.15.10.2104, 8.15.10.2102, 8.771.1.0; atiumd64.dll: 7.14.10.833, 7.14.10.867, 7.14.10.885, 7.14.10.903, 7.14.10.911, 8.14.10.768, 9.14.10.1001, 9.14.10.1017, 9.14.10.1080, 9.14.10.1128, 9.14.10.1162, 9.14.10.1171, 9.14.10.1183, 9.14.10.1197, 9.14.10.945, 9.14.10.972, 9.14.10.984, 9.14.10.996");
@@ -426,11 +410,8 @@ pref("media.decoder-doctor.verbose", false);
pref("media.decoder-doctor.wmf-disabled-is-failure", false);
// Whether to suspend decoding of videos in background tabs.
-#ifdef NIGHTLY_BUILD
-pref("media.suspend-bkgnd-video.enabled", true);
-#else
pref("media.suspend-bkgnd-video.enabled", false);
-#endif
+
// Delay, in ms, from time window goes to background to suspending
// video decoders. Defaults to 10 seconds.
pref("media.suspend-bkgnd-video.delay-ms", 10000);
@@ -561,11 +542,7 @@ pref("apz.peek_messages.enabled", true);
// Whether to print the APZC tree for debugging
pref("apz.printtree", false);
-#ifdef NIGHTLY_BUILD
-pref("apz.record_checkerboarding", true);
-#else
pref("apz.record_checkerboarding", false);
-#endif
pref("apz.test.logging_enabled", false);
pref("apz.touch_start_tolerance", "0.1");
pref("apz.touch_move_tolerance", "0.03");
@@ -1131,11 +1108,7 @@ pref("javascript.options.mem.log", false);
pref("javascript.options.mem.notify", false);
pref("javascript.options.gc_on_memory_pressure", true);
pref("javascript.options.compact_on_user_inactive", true);
-#ifdef NIGHTLY_BUILD
-pref("javascript.options.compact_on_user_inactive_delay", 15000); // ms
-#else
pref("javascript.options.compact_on_user_inactive_delay", 300000); // ms
-#endif
pref("javascript.options.mem.gc_high_frequency_time_limit_ms", 1000);
pref("javascript.options.mem.gc_high_frequency_low_limit_mb", 100);
@@ -2370,12 +2343,8 @@ pref("layout.css.prefixes.device-pixel-ratio-webkit", false);
// Is the CSS Unprefixing Service enabled? (This service emulates support
// for certain vendor-prefixed properties & values, for sites on a "fixlist".)
pref("layout.css.unprefixing-service.enabled", true);
-#ifdef NIGHTLY_BUILD
// Is the CSS Unprefixing Service whitelisted for all domains?
-// (This pref is only honored in Nightly builds and can be removed when
-// Bug 1177263 is fixed.)
pref("layout.css.unprefixing-service.globally-whitelisted", false);
-#endif
// Is support for the :scope selector enabled?
pref("layout.css.scope-pseudo.enabled", true);
@@ -2583,10 +2552,6 @@ pref("hangmonitor.timeout", 0);
pref("plugins.load_appdir_plugins", false);
// If true, plugins will be click to play
pref("plugins.click_to_play", false);
-#ifdef NIGHTLY_BUILD
-// This only supports one hidden ctp plugin, edit nsPluginArray.cpp if adding a second
-pref("plugins.navigator.hidden_ctp_plugin", "Shockwave Flash");
-#endif
// The default value for nsIPluginTag.enabledState (STATE_ENABLED = 2)
pref("plugin.default.state", 2);
@@ -3826,10 +3791,6 @@ pref("layers.acceleration.force", false);
// and output the result to stderr.
pref("layers.bench.enabled", false);
-#if defined(XP_WIN) && defined(NIGHTLY_BUILD)
-pref("layers.gpu-process.dev.enabled", true);
-#endif
-
pref("layers.acceleration.draw-fps", false);
// Enable DEAA antialiasing for transformed layers in the compositor
@@ -3968,11 +3929,7 @@ pref("notification.feature.enabled", false);
pref("dom.webnotifications.enabled", true);
pref("dom.webnotifications.serviceworker.enabled", true);
pref("dom.webnotifications.requireinteraction.count", 3);
-#ifdef NIGHTLY_BUILD
-pref("dom.webnotifications.requireinteraction.enabled", true);
-#else
pref("dom.webnotifications.requireinteraction.enabled", false);
-#endif
// Alert animation effect, name is disableSlidingEffect for backwards-compat.
pref("alerts.disableSlidingEffect", false);
@@ -4352,11 +4309,9 @@ pref("dom.mozSettings.SettingsService.verbose.enabled", false);
pref("dom.mozSettings.allowForceReadOnly", false);
// The interval at which to check for slow running addons
-#ifdef NIGHTLY_BUILD
-pref("browser.addon-watch.interval", 15000);
-#else
+// -1 = don't use this and don't bug users with crappy inaccurate measurements.
+// TODO: remove this.
pref("browser.addon-watch.interval", -1);
-#endif
pref("browser.addon-watch.ignore", "[\"mochikit@mozilla.org\",\"special-powers@mozilla.org\",\"fxdevtools-adapters@mozilla.org\",\"fx-devtools\"]");
// Search service settings
diff --git a/system/graphics/src/DriverCrashGuard.cpp b/system/graphics/src/DriverCrashGuard.cpp
index 3b69d387c..333c624e9 100644
--- a/system/graphics/src/DriverCrashGuard.cpp
+++ b/system/graphics/src/DriverCrashGuard.cpp
@@ -68,19 +68,11 @@ AreCrashGuardsEnabled()
if (XRE_IsGPUProcess()) {
return false;
}
-#ifdef NIGHTLY_BUILD
- // We only use the crash guard on non-nightly channels, since the nightly
- // channel is for development and having graphics features perma-disabled
- // is rather annoying. Unless the user forces is with an environment
- // variable, which comes in handy for testing.
- return gfxEnv::ForceCrashGuardNightly();
-#else
// Check to see if all guards have been disabled through the environment.
if (gfxEnv::DisableCrashGuard()) {
return false;
}
return true;
-#endif
}
void
diff --git a/system/graphics/thebes/gfxEnv.h b/system/graphics/thebes/gfxEnv.h
index ff4a8063a..e1e491a9b 100644
--- a/system/graphics/thebes/gfxEnv.h
+++ b/system/graphics/thebes/gfxEnv.h
@@ -42,7 +42,6 @@ public:
// Disabling the crash guard in DriverCrashGuard
DECL_GFX_ENV("MOZ_DISABLE_CRASH_GUARD", DisableCrashGuard);
- DECL_GFX_ENV("MOZ_FORCE_CRASH_GUARD_NIGHTLY", ForceCrashGuardNightly);
// We force present to work around some Windows bugs - disable that if this
// environment variable is set.
diff --git a/system/packager/base.mk b/system/packager/base.mk
index fb1114575..b475f6ed1 100644
--- a/system/packager/base.mk
+++ b/system/packager/base.mk
@@ -86,10 +86,6 @@ DEFINES += -DMOZ_D3DCOMPILER_XP_DLL=$(MOZ_D3DCOMPILER_XP_DLL)
endif
endif
-ifdef NIGHTLY_BUILD
-DEFINES += -DNIGHTLY_BUILD=1
-endif
-
ifdef MOZ_ENABLE_GNOME_COMPONENT
DEFINES += -DMOZ_ENABLE_GNOME_COMPONENT=1
endif