summaryrefslogtreecommitdiff
path: root/old-configure.in
diff options
context:
space:
mode:
authorMoonchild <moonchild@palemoon.org>2022-01-21 22:22:07 +0000
committerMoonchild <moonchild@palemoon.org>2022-01-21 22:22:07 +0000
commitdc98a078df30e1e66290f51b1ca4ff4ca52bff0b (patch)
treeb090489cc35970b9b72428059991035893867983 /old-configure.in
parentfb553633f9d12bfdb0aa91e769ad295a869a9373 (diff)
downloadaura-central-dc98a078df30e1e66290f51b1ca4ff4ca52bff0b.tar.gz
Issue %3053 - Part 5: Update mar file generation scripts for use of xz.
- Update scripts to support both lzma and bzip2 - Update python script to support lzma - Add a configure switch to use the old bzip2 format (default=xz) - Update test scripts to support lzma to be thorough This all requires xz to be available in the path on the build system.
Diffstat (limited to 'old-configure.in')
-rw-r--r--old-configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/old-configure.in b/old-configure.in
index a8c369398..2e6a6938c 100644
--- a/old-configure.in
+++ b/old-configure.in
@@ -3119,6 +3119,19 @@ if test -n "$MOZ_UPDATER"; then
fi
dnl ========================================================
+dnl Use old MAR format (bzip2)?
+dnl ========================================================
+
+MOZ_ARG_ENABLE_BOOL(updater,
+[ --enable-old-mar Use the old style MAR update format (bzip2)],
+ MAR_OLD_FORMAT=1,
+ MAR_OLD_FORMAT= )
+
+if test -n "$MAR_OLD_FORMAT"; then
+ AC_DEFINE(MAR_OLD_FORMAT)
+fi
+
+dnl ========================================================
dnl Build the tests?
dnl ========================================================
MOZ_ARG_ENABLE_BOOL(tests,
@@ -4344,6 +4357,7 @@ AC_SUBST(MOZ_SPELLCHECK)
AC_SUBST(MOZ_VERIFY_MAR_SIGNATURE)
AC_SUBST(MOZ_ENABLE_SIGNMAR)
AC_SUBST(MOZ_UPDATER)
+AC_SUBST(MAR_OLD_FORMAT)
AC_SUBST(MOZ_ANGLE_RENDERER)
AC_SUBST(MOZ_D3D_CPU_SUFFIX)