summaryrefslogtreecommitdiff
path: root/old-configure.in
diff options
context:
space:
mode:
authorMoonchild <moonchild@palemoon.org>2021-10-16 12:05:58 +0000
committerMoonchild <moonchild@palemoon.org>2021-10-16 12:05:58 +0000
commit80c43057159f640dfcd21dffeade7c29e052405f (patch)
tree0c5482405d56d7488af9240d9701a5848358b770 /old-configure.in
parent1ba7ef8edb18d625f902ecf2a195ab22f26ebaa8 (diff)
downloadaura-central-80c43057159f640dfcd21dffeade7c29e052405f.tar.gz
Issue %3020 - Part 8: Remove MOZ_LINKER
This also removes the XZ Embedded decompressor because it was only used with the custom liker.
Diffstat (limited to 'old-configure.in')
-rw-r--r--old-configure.in32
1 files changed, 1 insertions, 31 deletions
diff --git a/old-configure.in b/old-configure.in
index d88e24815..2201ebb4f 100644
--- a/old-configure.in
+++ b/old-configure.in
@@ -1078,13 +1078,6 @@ AC_SUBST_LIST(SSE_FLAGS)
AC_SUBST_LIST(SSE2_FLAGS)
AC_SUBST_LIST(SSSE3_FLAGS)
-AC_SUBST(MOZ_LINKER)
-if test -n "$MOZ_LINKER"; then
- AC_DEFINE(MOZ_LINKER)
- MOZ_LINKER_EXTRACT=1
- AC_CHECK_PROGS(XZ, xz)
-fi
-
dnl Only one oddball right now (QNX), but this gives us flexibility
dnl if any other platforms need to override this in the future.
AC_DEFINE_UNQUOTED(D_INO,$DIRENT_INO)
@@ -1682,7 +1675,7 @@ AC_CACHE_CHECK(for __thread keyword for TLS variables,
LDFLAGS=$_SAVE_LDFLAGS
# The custom dynamic linker doesn't support TLS variables
MOZ_TLS=
-if test "$ac_cv_thread_keyword" = yes -a "$MOZ_LINKER" != 1; then
+if test "$ac_cv_thread_keyword" = yes; then
# mips builds fail with TLS variables because of a binutils bug.
# See bug 528687
# OpenBSD doesn't have TLS support, and the test succeeds with clang++
@@ -1700,23 +1693,6 @@ if test "$ac_cv_thread_keyword" = yes -a "$MOZ_LINKER" != 1; then
esac
fi
-dnl Using the custom linker on ARMv6 requires 16k alignment of ELF segments.
-if test -n "$MOZ_LINKER"; then
- if test "$CPU_ARCH" = arm; then
- dnl When building for < ARMv7, we need to ensure 16k alignment of ELF segments
- if test -n "$ARM_ARCH" && test "$ARM_ARCH" -lt 7; then
- LDFLAGS="$LDFLAGS -Wl,-z,max-page-size=0x4000 -Wl,-z,common-page-size=0x4000"
- _SUBDIR_LDFLAGS="$_SUBDIR_LDFLAGS -Wl,-z,max-page-size=0x4000 -Wl,-z,common-page-size=0x4000"
- fi
- fi
-
-dnl gold emits wrong sysv-style elf hash tables when building both sysv and
-dnl style tables. https://sourceware.org/bugzilla/show_bug.cgi?id=13597
-dnl Since the linker only understands the sysv ones, no need to build the
-dnl gnu style tables anyways.
- LDFLAGS="$LDFLAGS -Wl,--hash-style=sysv"
-fi
-
dnl See if compiler supports some gcc-style attributes
AC_CACHE_CHECK(for __attribute__((always_inline)),
@@ -1848,10 +1824,6 @@ dnl system ZLIB support
dnl ========================================================
MOZ_ZLIB_CHECK([1.2.3])
-if test "$MOZ_LINKER" = 1 -a "$MOZ_SYSTEM_ZLIB" != 1; then
- AC_MSG_ERROR([Custom dynamic linker requires --with-system-zlib])
-fi
-
if test -z "$SKIP_LIBRARY_CHECKS"; then
dnl system BZIP2 Support
dnl ========================================================
@@ -4613,7 +4585,6 @@ AC_SUBST(MOZ_COMPONENTS_VERSION_SCRIPT_LDFLAGS)
AC_SUBST(MOZ_FIX_LINK_PATHS)
AC_SUBST(MOZ_POST_PROGRAM_COMMAND)
-AC_SUBST(MOZ_LINKER_EXTRACT)
AC_SUBST(MOZ_JSDOWNLOADS)
if test -n "$MOZ_JSDOWNLOADS"; then
@@ -5179,7 +5150,6 @@ export STLPORT_CPPFLAGS
export STLPORT_LIBS
unset MOZ_BUILD_APP
export DIST
-export MOZ_LINKER
export ZLIB_IN_MOZGLUE
export AR
export RANLIB