summaryrefslogtreecommitdiff
path: root/modules/libpref
diff options
context:
space:
mode:
authorMoonchild <moonchild@palemoon.org>2020-08-08 19:59:24 +0000
committerGitHub <noreply@github.com>2020-08-08 19:59:24 +0000
commit59aed65868825a090963f7f5007e88be32234a7a (patch)
tree72d7c3850d18118ba0f3eb571ebf27f3a11d5373 /modules/libpref
parented32b75a46f52e4313fcd2c939d2ca0b7d86b364 (diff)
parentae026ba381d059e4e18bd451b30215269ceddfee (diff)
downloadaura-central-59aed65868825a090963f7f5007e88be32234a7a.tar.gz
Merge pull request %1613 from RealityRipple/AspectRatio
[Image/CSS] Intrinsic Aspect Ratio
Diffstat (limited to 'modules/libpref')
-rw-r--r--modules/libpref/init/all.js6
1 files changed, 6 insertions, 0 deletions
diff --git a/modules/libpref/init/all.js b/modules/libpref/init/all.js
index 58e02c1af..d4b86731d 100644
--- a/modules/libpref/init/all.js
+++ b/modules/libpref/init/all.js
@@ -4811,6 +4811,12 @@ pref("media.ondevicechange.fakeDeviceChangeEvent.enabled", false);
// those platforms we don't handle touch events anyway so it's conceptually
// a no-op.
pref("layout.css.touch_action.enabled", true);
+
+// WHATWG computed intrinsic aspect ratio for an img element
+// https://html.spec.whatwg.org/multipage/rendering.html#attributes-for-embedded-content-and-images
+// Are the width and height attributes on image-like elements mapped to the
+// internal-for-now aspect-ratio property?
+pref("layout.css.intrinsic-aspect-ratio.enabled", true);
// Enables some assertions in nsStyleContext that are too expensive
// for general use, but might be useful to enable for specific tests.