summaryrefslogtreecommitdiff
path: root/js
diff options
context:
space:
mode:
authorJustOff <Off.Just.Off@gmail.com>2018-05-04 17:28:00 +0300
committerJustOff <Off.Just.Off@gmail.com>2018-05-04 17:28:00 +0300
commitce4688a46341353511a3cc53ad6ff9b9bc4e8dbc (patch)
tree036a8f5746f29e33e8897e2e5590de6903be2920 /js
parent29a10899edbc20e20872d54a92ca45949ad9e503 (diff)
downloadaura-central-ce4688a46341353511a3cc53ad6ff9b9bc4e8dbc.tar.gz
Fix regex escaping in old-configure and js/src/old-configure
Diffstat (limited to 'js')
-rw-r--r--js/src/old-configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/js/src/old-configure.in b/js/src/old-configure.in
index 162a071d7..8abea5956 100644
--- a/js/src/old-configure.in
+++ b/js/src/old-configure.in
@@ -734,12 +734,14 @@ case "$target" in
dnl VS2012+ defaults to -arch:SSE2. We want to target nothing
dnl more recent, so set that explicitly here unless another
dnl target arch has already been set.
+ changequote(,)
if test -z `echo $CFLAGS | grep -i [-/]arch:` ; then
CFLAGS="$CFLAGS -arch:SSE2"
- fi
+ fi
if test -z `echo $CXXFLAGS | grep -i [-/]arch:` ; then
CXXFLAGS="$CXXFLAGS -arch:SSE2"
fi
+ changequote([,])
fi
dnl VS2013+ requires -FS when parallel building by make -jN.
dnl If nothing, compiler sometimes causes C1041 error.