summaryrefslogtreecommitdiff
path: root/js
diff options
context:
space:
mode:
authortrav90 <travawine@palemoon.org>2022-04-16 13:38:50 -0500
committerMatt A. Tobin <email@mattatobin.com>2022-04-16 13:52:46 -0500
commitf13d3569f4c2606ff90978d74bed33ba1db82556 (patch)
tree4f332b420fabef43fb97665cd93fc49baa9b9352 /js
parent3db2172afe31ff6658909bd884b3429b0e9143e1 (diff)
downloadaura-central-f13d3569f4c2606ff90978d74bed33ba1db82556.tar.gz
Issue #22 - Always use -pipe with GCC
Usable GCC versions have supported -pipe for a VERY long time. There's no need to keep checking if it is supported.
Diffstat (limited to 'js')
-rw-r--r--js/src/old-configure.in13
1 files changed, 0 insertions, 13 deletions
diff --git a/js/src/old-configure.in b/js/src/old-configure.in
index 197f0428f..b493bd58b 100644
--- a/js/src/old-configure.in
+++ b/js/src/old-configure.in
@@ -1897,19 +1897,6 @@ dnl ========================================================
MOZ_ARG_HEADER(Compiler Options)
dnl ========================================================
-dnl Check for gcc -pipe support
-dnl ========================================================
-AC_MSG_CHECKING([for -pipe support])
-if test -n "$GNU_CC" -a -n "$GNU_CXX"; then
- dnl Any gcc that supports firefox supports -pipe.
- CFLAGS="$CFLAGS -pipe"
- CXXFLAGS="$CXXFLAGS -pipe"
- AC_MSG_RESULT([yes])
-else
- AC_MSG_RESULT([no])
-fi
-
-dnl ========================================================
dnl Profile guided optimization (gcc checks)
dnl ========================================================
dnl Test for profiling options