summaryrefslogtreecommitdiff
path: root/build
diff options
context:
space:
mode:
authorMatt A. Tobin <email@mattatobin.com>2019-02-21 18:27:58 -0500
committerMatt A. Tobin <email@mattatobin.com>2019-02-21 18:27:58 -0500
commit5c2dc814a54f259bdbf21b53f000c91863f3375d (patch)
treee4f4321ce9ddea7c5d056d897ca1e51feed28411 /build
parent926357219444099bb1f95c27f2cc6cc58dd845cc (diff)
downloadaura-central-5c2dc814a54f259bdbf21b53f000c91863f3375d.tar.gz
[CENTRAL] Remove junk left over from comm-central
Diffstat (limited to 'build')
-rw-r--r--build/autoconf/check-sync-exceptions2
-rw-r--r--build/check-sync-exceptions17
-rw-r--r--build/client.py-args1
-rw-r--r--build/client.py-l10n-args1
-rw-r--r--build/dumbmake-dependencies6
-rw-r--r--build/merge-installrdf.py24
-rw-r--r--build/mozconfig.automation33
-rw-r--r--build/mozconfig.cache135
-rw-r--r--build/mozconfig.common26
-rw-r--r--build/pymake/make.py10
10 files changed, 1 insertions, 254 deletions
diff --git a/build/autoconf/check-sync-exceptions b/build/autoconf/check-sync-exceptions
deleted file mode 100644
index 005bb6b5e..000000000
--- a/build/autoconf/check-sync-exceptions
+++ /dev/null
@@ -1,2 +0,0 @@
-mozconfig-find
-mozconfig2client-mk
diff --git a/build/check-sync-exceptions b/build/check-sync-exceptions
deleted file mode 100644
index de0da9f6f..000000000
--- a/build/check-sync-exceptions
+++ /dev/null
@@ -1,17 +0,0 @@
-dumbmake-dependencies
-mach_bootstrap.py
-merge-installrdf.py
-pymake
-client.py-args
-client.py-l10n-args
-configobj.py
-
-# Ignore detritus left lying around by editing tools.
-*~
-.#*
-#*#
-*.orig
-*.rej
-
-# Ignore "compiled" python files
-*.pyc
diff --git a/build/client.py-args b/build/client.py-args
deleted file mode 100644
index 4f38e4ea2..000000000
--- a/build/client.py-args
+++ /dev/null
@@ -1 +0,0 @@
---hg-options='--time' --hgtool=../tools/buildfarm/utils/hgtool.py --hgtool1=../scripts/buildfarm/utils/hgtool.py --skip-chatzilla --skip-comm --skip-inspector --tinderbox-print --mozilla-repo=https://hg.mozilla.org/releases/mozilla-esr52 --mozilla-rev=THUNDERBIRD_52_VERBRANCH
diff --git a/build/client.py-l10n-args b/build/client.py-l10n-args
deleted file mode 100644
index 4f38e4ea2..000000000
--- a/build/client.py-l10n-args
+++ /dev/null
@@ -1 +0,0 @@
---hg-options='--time' --hgtool=../tools/buildfarm/utils/hgtool.py --hgtool1=../scripts/buildfarm/utils/hgtool.py --skip-chatzilla --skip-comm --skip-inspector --tinderbox-print --mozilla-repo=https://hg.mozilla.org/releases/mozilla-esr52 --mozilla-rev=THUNDERBIRD_52_VERBRANCH
diff --git a/build/dumbmake-dependencies b/build/dumbmake-dependencies
index 7704a681a..e69de29bb 100644
--- a/build/dumbmake-dependencies
+++ b/build/dumbmake-dependencies
@@ -1,6 +0,0 @@
-im/app
- chat
- im
- mozilla/extensions/purple
-chat
- im
diff --git a/build/merge-installrdf.py b/build/merge-installrdf.py
deleted file mode 100644
index 7a211c349..000000000
--- a/build/merge-installrdf.py
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/usr/bin/python
-# This Source Code Form is subject to the terms of the Mozilla Public
-# License, v. 2.0. If a copy of the MPL was not distributed with this
-# file, You can obtain one at http://mozilla.org/MPL/2.0/.
-
-# Get the target platform from a set of install.rdf files, and
-# return the first install.rdf with the platform replaced by the list of
-# platforms as parsed from all the files
-# Allows to create a install.rdf for multiple platforms
-
-import sys
-from xml.dom.minidom import parse
-
-elems = []
-for arg in sys.argv[2:]:
- doc = parse(arg + "/install.rdf")
- elem = doc.getElementsByTagName("em:targetPlatform")[0]
- elems.append(elem.cloneNode(True))
-
-doc = parse(sys.argv[1] + "/install.rdf")
-elem = doc.getElementsByTagName("em:targetPlatform")[0]
-for newelem in elems:
- elem.parentNode.insertBefore(newelem, elem)
-print doc.toxml()
diff --git a/build/mozconfig.automation b/build/mozconfig.automation
deleted file mode 100644
index 057a4a0b5..000000000
--- a/build/mozconfig.automation
+++ /dev/null
@@ -1,33 +0,0 @@
-# This Source Code Form is subject to the terms of the Mozilla Public
-# License, v. 2.0. If a copy of the MPL was not distributed with this
-# file, You can obtain one at http://mozilla.org/MPL/2.0/.
-
-# Common mozconfig for automation builds.
-#
-# We export MOZ_AUTOMATION_* variables here to trigger various steps in
-# automation builds. For example, if MOZ_AUTOMATION_PACKAGE is set, then the
-# package step will run. This file contains the default settings, which can be
-# overridden by setting them earlier in the appropriate mozconfig.
-
-mk_add_options "export MOZ_AUTOMATION_BUILD_SYMBOLS=${MOZ_AUTOMATION_BUILD_SYMBOLS-1}"
-mk_add_options "export MOZ_AUTOMATION_L10N_CHECK=${MOZ_AUTOMATION_L10N_CHECK-1}"
-mk_add_options "export MOZ_AUTOMATION_PACKAGE=${MOZ_AUTOMATION_PACKAGE-1}"
-mk_add_options "export MOZ_AUTOMATION_PACKAGE_TESTS=${MOZ_AUTOMATION_PACKAGE_TESTS-1}"
-mk_add_options "export MOZ_AUTOMATION_INSTALLER=${MOZ_AUTOMATION_INSTALLER-0}"
-mk_add_options "export MOZ_AUTOMATION_UPDATE_PACKAGING=${MOZ_AUTOMATION_UPDATE_PACKAGING-0}"
-mk_add_options "export MOZ_AUTOMATION_UPLOAD=${MOZ_AUTOMATION_UPLOAD-1}"
-mk_add_options "export MOZ_AUTOMATION_UPLOAD_SYMBOLS=${MOZ_AUTOMATION_UPLOAD_SYMBOLS-0}"
-mk_add_options "export MOZ_AUTOMATION_SDK=${MOZ_AUTOMATION_SDK-0}"
-
-# If we are also building with MOZ_PKG_PRETTYNAMES, set the corresponding
-# stages.
-if test "$MOZ_AUTOMATION_PRETTY" = "1"; then
- mk_add_options "export MOZ_AUTOMATION_PRETTY_PACKAGE=${MOZ_AUTOMATION_PACKAGE-1}"
- mk_add_options "export MOZ_AUTOMATION_PRETTY_PACKAGE_TESTS=${MOZ_AUTOMATION_PACKAGE_TESTS-1}"
- mk_add_options "export MOZ_AUTOMATION_PRETTY_L10N_CHECK=${MOZ_AUTOMATION_L10N_CHECK-1}"
- mk_add_options "export MOZ_AUTOMATION_PRETTY_INSTALLER=${MOZ_AUTOMATION_INSTALLER-0}"
-
- # Note that we always build the update packaging with pretty names even if
- # we don't build it without, so this is set to 1.
- mk_add_options "export MOZ_AUTOMATION_PRETTY_UPDATE_PACKAGING=1"
-fi
diff --git a/build/mozconfig.cache b/build/mozconfig.cache
deleted file mode 100644
index be740e293..000000000
--- a/build/mozconfig.cache
+++ /dev/null
@@ -1,135 +0,0 @@
-# This Source Code Form is subject to the terms of the Mozilla Public
-# License, v. 2.0. If a copy of the MPL was not distributed with this
-# file, You can obtain one at http://mozilla.org/MPL/2.0/.
-
-# Setup for build cache
-
-# Avoid duplication if the file happens to be included twice.
-if test -z "$bucket" -a -z "$NO_CACHE"; then
-
-# buildbot (or builders that use buildprops.json):
-if [ -f $topsrcdir/../buildprops.json ]; then
-read branch platform master <<EOF
-$(python2.7 -c 'import json; p = json.loads(open("'"$topsrcdir"'/../buildprops.json").read())["properties"]; print p["branch"], p["platform"], p["master"]' 2> /dev/null)
-EOF
-
-bucket=
-if test -z "$SCCACHE_DISABLE" -a -z "$no_sccache" -a -z "$MOZ_PGO_IS_SET" -a -z "$MOZ_PGO"; then
- case "${branch}" in
- try)
- case "${master}" in
- *scl1.mozilla.com*|*.scl3.mozilla.com*)
- bucket=mozilla-releng-s3-cache-us-west-1-try
- ;;
- *use1.mozilla.com*)
- bucket=mozilla-releng-s3-cache-us-east-1-try
- ;;
- *usw2.mozilla.com*)
- bucket=mozilla-releng-s3-cache-us-west-2-try
- ;;
- esac
- ;;
- autoland|mozilla-inbound)
- case "${master}" in
- *use1.mozilla.com*)
- bucket=mozilla-releng-s3-cache-us-east-1-prod
- ;;
- *usw2.mozilla.com*)
- bucket=mozilla-releng-s3-cache-us-west-2-prod
- ;;
- esac
- ;;
- esac
-fi
-
-# builds without buildprops (eg: taskcluster or non-buildbot) and without ccache env config and without sccache disabled:
-elif test -z "$CCACHE_DIR" -a -z "$SCCACHE_DISABLE" -a -z "$no_sccache" -a -z "$MOZ_PGO_IS_SET" -a -z "$MOZ_PGO"; then
-
- # prevent rerun if az is set, or wget is not available
- if test -z "$availability_zone" -a -x "$(command -v wget)"; then
- # timeout after 1 second, and don't retry (failure indicates instance is not in ec2 or network issue)
- # availability_zone is of the form <region><letter> where region is e.g. us-west-2, and az is us-west-2a
- availability_zone=$(wget -T 1 -t 1 -q -O - http://169.254.169.254/latest/meta-data/placement/availability-zone || true)
- if test -z "$availability_zone" -o "$availability_zone" = "not-ec2"; then
- availability_zone=not-ec2
- else
- # region is az with last letter trimmed
- region=${availability_zone%?}
- # set S3 bucket according to tree (level)
- case "${GECKO_HEAD_REPOSITORY}" in
- *hg.mozilla.org/try*)
- bucket=taskcluster-level-1-sccache-${region}
- ;;
- *hg.mozilla.org/integration/autoland*|*hg.mozilla.org/integration/mozilla-inbound*)
- bucket=taskcluster-level-3-sccache-${region}
- ;;
- esac
-
- # set a dummy master
- case "${region}" in
- eu-central-1)
- master=dummy.euc1.mozilla.com
- ;;
- us-east-1)
- master=dummy.use1.mozilla.com
- ;;
- us-west-1)
- master=dummy.usw1.mozilla.com
- ;;
- us-west-2)
- master=dummy.usw2.mozilla.com
- ;;
- esac
- fi
- fi
-fi
-
-# if platform hasn't been determined from buildprops, and we're on windows,
-# it must be set to prevent adding ac_add_options --with-ccache below
-if test -z "$platform"; then
- # set platform based on the SYSTEMROOT env var
- case "${SYSTEMROOT}" in
- *Windows)
- platform=windows
- ;;
- esac
-fi
-
-if test -z "$bucket"; then
- case "$platform" in
- win*) : ;;
- *)
- ac_add_options --with-ccache
- esac
-else
- if ! test -e $topsrcdir/sccache/sccache.py; then
- echo "Sccache missing in the tooltool manifest" >&2
- exit 1
- fi
- mk_add_options "export SCCACHE_BUCKET=$bucket"
- case "$master" in
- *us[ew][12].mozilla.com*|*euc1.mozilla.com*)
- mk_add_options "export SCCACHE_NAMESERVER=169.254.169.253"
- ;;
- esac
- ac_add_options "--with-compiler-wrapper=python2.7 $topsrcdir/sccache/sccache.py"
- mk_add_options MOZ_PREFLIGHT_ALL+=build/sccache.mk
- mk_add_options MOZ_POSTFLIGHT_ALL+=build/sccache.mk
- mk_add_options "UPLOAD_EXTRA_FILES+=sccache.log.gz"
- case "$platform" in
- win*)
- # sccache supports a special flag to create depfiles.
- export _DEPEND_CFLAGS='-deps$(MDDEPDIR)/$(@F).pp'
- # Windows builds have a default wrapper that needs to be overridden
- mk_add_options "export CC_WRAPPER="
- mk_add_options "export CXX_WRAPPER="
- # For now, sccache doesn't support separate PDBs so force debug info to be
- # in object files.
- mk_add_options "export COMPILE_PDB_FLAG="
- mk_add_options "export HOST_PDB_FLAG="
- mk_add_options "export MOZ_DEBUG_FLAGS=-Z7"
- ;;
- esac
-fi
-
-fi
diff --git a/build/mozconfig.common b/build/mozconfig.common
deleted file mode 100644
index 3d2d0b289..000000000
--- a/build/mozconfig.common
+++ /dev/null
@@ -1,26 +0,0 @@
-# This Source Code Form is subject to the terms of the Mozilla Public
-# License, v. 2.0. If a copy of the MPL was not distributed with this
-# file, You can obtain one at http://mozilla.org/MPL/2.0/.
-
-# Common mozconfig for official builds.
-#
-# Add options to this file that will be inherited by all in-tree mozconfigs.
-# This is useful for eg try builds with nondefault options that apply to all
-# architectures, though note that if you want to override options set in
-# another mozconfig file, you'll need to use mozconfig.common.override instead
-# of this file.
-
-mk_add_options AUTOCLOBBER=1
-
-ac_add_options --enable-crashreporter
-
-ac_add_options --enable-release
-
-# Disable checking that add-ons are signed by the trusted root
-MOZ_ADDON_SIGNING=${MOZ_ADDON_SIGNING-0}
-# Disable enforcing that add-ons are signed by the trusted root
-MOZ_REQUIRE_SIGNING=${MOZ_REQUIRE_SIGNING-0}
-
-ac_add_options --enable-js-shell
-
-. "$topsrcdir/build/mozconfig.automation"
diff --git a/build/pymake/make.py b/build/pymake/make.py
index 178bdd747..a78bfff4f 100644
--- a/build/pymake/make.py
+++ b/build/pymake/make.py
@@ -16,8 +16,6 @@ def getpath(relpath):
return os.path.abspath(os.path.join(thisdir, *relpath))
PYMAKE = getpath(["..", "..", "mozilla", "build", "pymake", "make.py"])
-CLIENT_PY = getpath(["..", "..", "client.py"])
-CLIENT_PY_ARGS = getpath(["..", "client.py-args"])
def main(args):
if 'TINDERBOX_OUTPUT' in os.environ:
@@ -34,13 +32,7 @@ def main(args):
sys.exit(subprocess.call(cmd))
if not os.path.exists(PYMAKE):
- clientpyargs = open(CLIENT_PY_ARGS, "r").read().strip()
- clientpyargs = shlex.split(clientpyargs)
- subprocess.check_call([sys.executable, CLIENT_PY, "checkout"] +
- clientpyargs)
-
- if not os.path.exists(PYMAKE):
- raise Exception("Pymake not found even after client.py was run")
+ raise Exception("Pymake not found")
subprocess.check_call([sys.executable, PYMAKE] + args)