summaryrefslogtreecommitdiff
path: root/build/pymake/tests/parallel-simple.mk
diff options
context:
space:
mode:
authorMatt A. Tobin <email@mattatobin.com>2022-10-05 14:14:19 -0500
committerMatt A. Tobin <email@mattatobin.com>2022-10-05 14:14:19 -0500
commite4ed223f80260aa735a77bc4cfff25b76f3e7a94 (patch)
treee890a72e87bfcf0b17ba9f4ee343f8b8eaf39389 /build/pymake/tests/parallel-simple.mk
parent22e29728789d598287d22bc290af666940937dd4 (diff)
downloadaura-central-e4ed223f80260aa735a77bc4cfff25b76f3e7a94.tar.gz
[RES2] Move pymake to python/ and remove a bunch of mozconfig and other half-out-of-date MozInfra items from build/
Diffstat (limited to 'build/pymake/tests/parallel-simple.mk')
-rw-r--r--build/pymake/tests/parallel-simple.mk27
1 files changed, 0 insertions, 27 deletions
diff --git a/build/pymake/tests/parallel-simple.mk b/build/pymake/tests/parallel-simple.mk
deleted file mode 100644
index f1aafc5f1..000000000
--- a/build/pymake/tests/parallel-simple.mk
+++ /dev/null
@@ -1,27 +0,0 @@
-#T commandline: ['-j2']
-
-# CAUTION: this makefile is also used by serial-toparallel.mk
-
-define SLOWMAKE
-printf "$@:0:" >>results
-sleep 0.5
-printf "$@:1:" >>results
-sleep 0.5
-printf "$@:2:" >>results
-endef
-
-EXPECTED = target1:0:target2:0:target1:1:target2:1:target1:2:target2:2:
-
-all:: target1 target2
- cat results
- test "$$(cat results)" = "$(EXPECTED)"
- @echo TEST-PASS
-
-target1:
- $(SLOWMAKE)
-
-target2:
- sleep 0.1
- $(SLOWMAKE)
-
-.PHONY: all