summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorMatt A. Tobin <email@mattatobin.com>2021-10-30 19:05:33 -0400
committerMatt A. Tobin <email@mattatobin.com>2021-10-30 19:05:33 -0400
commitd6ea3201b3f578d8590fddb395759483e75b6221 (patch)
treeadd1ee9c886bda910cb32df2ba6665dd50dfa172 /Makefile.in
parentabc16648c3bcccd785ab5708f02f39947d7dd3fa (diff)
downloadaura-central-d6ea3201b3f578d8590fddb395759483e75b6221.tar.gz
Issue %3031 - Remove FasterMake/FasterMake+RecursiveMake
- This includes anything to do with artifact builds. - This also removes configure options to specify build-backends and hardcodes RecursiveMake
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in30
1 files changed, 2 insertions, 28 deletions
diff --git a/Makefile.in b/Makefile.in
index 6c2327388..56befd9a0 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -137,16 +137,10 @@ default:: $(BUILD_BACKEND_FILES)
endif
install_manifests := \
- $(addprefix dist/,branding idl include public private sdk xpi-stage) \
+ $(addprefix dist/,branding bin idl include public private sdk xpi-stage) \
_tests \
$(NULL)
-# Skip the dist/bin install manifest when using the hybrid
-# FasterMake/RecursiveMake backend. This is a hack until bug 1241744 moves
-# xpidl handling to FasterMake in that case, mechanically making the dist/bin
-# install manifest non-existent (non-existent manifests being skipped)
-ifeq (,$(filter FasterMake+RecursiveMake,$(BUILD_BACKENDS)))
-install_manifests += dist/bin
-endif
+
install_manifest_depends = \
CLOBBER \
$(configure_dir)/configure \
@@ -166,17 +160,6 @@ endif
.PHONY: install-manifests
install-manifests: $(addprefix install-,$(install_manifests))
-# If we're using the hybrid FasterMake/RecursiveMake backend, we want
-# to recurse in the faster/ directory in parallel of install manifests.
-# But dist/idl needs to happen before (cf. dependencies in
-# config/faster/rules.mk)
-ifneq (,$(filter FasterMake+RecursiveMake,$(BUILD_BACKENDS)))
-install-manifests: faster
-.PHONY: faster
-faster: install-dist/idl
- $(MAKE) -C faster FASTER_RECURSIVE_MAKE=1
-endif
-
.PHONY: tup
tup:
$(call BUILDSTATUS,TIERS make tup)
@@ -198,17 +181,8 @@ endif
.PHONY: $(addprefix install-,$(subst /,_,$(install_manifests)))
$(addprefix install-,$(install_manifests)): install-%: $(install_manifest_depends)
-ifneq (,$(filter FasterMake+RecursiveMake,$(BUILD_BACKENDS)))
- @# If we're using the hybrid FasterMake/RecursiveMake backend, we want
- @# to ensure the FasterMake end doesn't have install manifests for the
- @# same directory, because that would blow up
- $(if $(wildcard _build_manifests/install/$(subst /,_,$*)),$(if $(wildcard faster/install_$(subst /,_,$*)*),$(error FasterMake and RecursiveMake ends of the hybrid build system want to handle $*)))
-endif
$(addprefix $(call py_action,process_install_manifest,$(if $(NO_REMOVE),--no-remove )$*) ,$(wildcard _build_manifests/install/$(subst /,_,$*)))
-# Dummy wrapper rule to allow the faster backend to piggy back
-$(addprefix install-,$(subst /,_,$(filter dist/%,$(install_manifests)))): install-dist_%: install-dist/% ;
-
.PHONY: install-tests
install-tests: install-test-files