summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Andrews <athenian200@outlook.com>2022-01-27 01:59:32 -0600
committerJeremy Andrews <athenian200@outlook.com>2022-01-27 01:59:32 -0600
commit631f58d95c9e27a60f0a99f82a1cf14614fa5214 (patch)
tree521ca8d10eece611d4bf03faf484f45a0b349bc8
parent69573363aacf8fd90c124393520a298a55a3b471 (diff)
downloadaura-central-631f58d95c9e27a60f0a99f82a1cf14614fa5214.tar.gz
[Packager] Use $(TOOLCHAIN_PREFIX) for cp command on SunOS.
The default cp command doesn't support -v for verbose output, so use gcp instead.
-rw-r--r--system/packager/installer.mk2
-rw-r--r--system/packager/packager.mk6
2 files changed, 4 insertions, 4 deletions
diff --git a/system/packager/installer.mk b/system/packager/installer.mk
index 991e942a8..a9c0447ec 100644
--- a/system/packager/installer.mk
+++ b/system/packager/installer.mk
@@ -55,7 +55,7 @@ installer:: stage-package
@rm -rf $(DIST)/installer-stage $(DIST)/xpt
@echo 'Staging installer files...'
@$(NSINSTALL) -D $(DIST)/installer-stage/core
- @cp -av $(DIST)/$(PKG_STAGE_DIR)/. $(DIST)/installer-stage/core
+ @$(TOOLCHAIN_PREFIX)cp -av $(DIST)/$(PKG_STAGE_DIR)/. $(DIST)/installer-stage/core
$(RM) -r $(CONFIG_DIR) && mkdir $(CONFIG_DIR)
$(MAKE) $(CONFIG_DIR)/setup.exe
$(INSTALL) $(CONFIG_DIR)/setup.exe $(DIST)/installer-stage
diff --git a/system/packager/packager.mk b/system/packager/packager.mk
index c281b67f7..85f008f6c 100644
--- a/system/packager/packager.mk
+++ b/system/packager/packager.mk
@@ -114,7 +114,7 @@ locale:
@test -f $(DIST)/bin/$(MOZ_APP_NAME)$(BIN_SUFFIX) || $(MAKE) regenerate-chrome
@echo 'Staging l10n files...'
@$(NSINSTALL) -D $(DIST)/$(PKG_XPI_L10N_STAGE_DIR)/chrome
- @cp -rv $(DIST)/bin/chrome/en-US.manifest $(DIST)/bin/chrome/en-US $(DIST)/$(PKG_XPI_L10N_STAGE_DIR)/chrome
+ @$(TOOLCHAIN_PREFIX)cp -rv $(DIST)/bin/chrome/en-US.manifest $(DIST)/bin/chrome/en-US $(DIST)/$(PKG_XPI_L10N_STAGE_DIR)/chrome
@echo manifest chrome/en-US.manifest > $(DIST)/$(PKG_XPI_L10N_STAGE_DIR)/chrome.manifest
$(call py_action,preprocessor,-Fsubstitution $(DEFINES) $(ACDEFINES) \
$(GREPKGR_PATH)/locale-install.rdf.in -o $(DIST)/$(PKG_XPI_L10N_STAGE_DIR)/install.rdf)
@@ -130,8 +130,8 @@ skin:
@test -f $(DIST)/bin/$(MOZ_APP_NAME)$(BIN_SUFFIX) || $(MAKE) regenerate-chrome
@echo 'Staging theme files...'
@$(NSINSTALL) -D $(DIST)/$(PKG_XPI_SKIN_STAGE_DIR)/chrome
- @cp -rv $(DIST)/bin/chrome/classic.manifest $(DIST)/bin/chrome/classic $(DIST)/$(PKG_XPI_SKIN_STAGE_DIR)/chrome
- @cp -rv $(DIST)/bin/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}/chrome.manifest $(DIST)/$(PKG_XPI_SKIN_STAGE_DIR)
+ @$(TOOLCHAIN_PREFIX)cp -rv $(DIST)/bin/chrome/classic.manifest $(DIST)/bin/chrome/classic $(DIST)/$(PKG_XPI_SKIN_STAGE_DIR)/chrome
+ @$(TOOLCHAIN_PREFIX)cp -rv $(DIST)/bin/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}/chrome.manifest $(DIST)/$(PKG_XPI_SKIN_STAGE_DIR)
@echo manifest chrome/classic.manifest >> $(DIST)/$(PKG_XPI_SKIN_STAGE_DIR)/chrome.manifest
$(call py_action,preprocessor,-Fsubstitution $(DEFINES) $(ACDEFINES) \
$(GREPKGR_PATH)/skin-install.rdf.in -o $(DIST)/$(PKG_XPI_SKIN_STAGE_DIR)/install.rdf)