summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt A. Tobin <email@mattatobin.com>2021-01-03 03:11:22 -0500
committerMoonchild <moonchild@palemoon.org>2021-03-15 22:16:14 +0000
commit2c885c3249161c8eb836abda35df351609fc5102 (patch)
treefdf8a4425e5a6c597723edee7ab57f9d7302a9d3
parentd8389063ee3d953d16233b20d4f56835633b7e04 (diff)
downloadaura-central-2c885c3249161c8eb836abda35df351609fc5102.tar.gz
[NSS hotpatch] Hard disable AVX2 in NSS Build System
-rw-r--r--security/nss/coreconf/arch.mk29
1 files changed, 5 insertions, 24 deletions
diff --git a/security/nss/coreconf/arch.mk b/security/nss/coreconf/arch.mk
index 790372d34..11633d8b9 100644
--- a/security/nss/coreconf/arch.mk
+++ b/security/nss/coreconf/arch.mk
@@ -143,30 +143,11 @@ endif
# Master "Core Components" macros for Hardware features #
#######################################################################
-ifndef NSS_DISABLE_AVX2
- ifneq ($(CPU_ARCH),x86_64)
- # Disable AVX2 entirely on non-Intel platforms
- NSS_DISABLE_AVX2 = 1
- $(warning CPU_ARCH is not x86_64, disabling -mavx2)
- else
- ifdef CC_IS_CLANG
- # Clang reports its version as an older gcc, but it's OK
- NSS_DISABLE_AVX2 = 0
- else
- ifneq (,$(filter 4.8 4.9,$(word 1,$(GCC_VERSION)).$(word 2,$(GCC_VERSION))))
- NSS_DISABLE_AVX2 = 0
- endif
- ifeq (,$(filter 0 1 2 3 4,$(word 1,$(GCC_VERSION))))
- NSS_DISABLE_AVX2 = 0
- endif
- endif
- ifndef NSS_DISABLE_AVX2
- $(warning Unable to find gcc 4.8 or greater, disabling -Werror)
- NSS_DISABLE_AVX2 = 1
- endif
- endif
- export NSS_DISABLE_AVX2
-endif #ndef NSS_DISABLE_AVX2
+# NSS Build system does not properly support MozillaBuild 2 MSYS1
+# So we simply aren't going to enable AVX2 at all
+# Plus there seems to be an issue with it anyway for other reasons
+NSS_DISABLE_AVX2 = 1
+export NSS_DISABLE_AVX2
#######################################################################
# Master "Core Components" macros for getting the OS target #